Unable to find function with name X for Message node Invalid Message Node

Everything works in editor but standalone crashes. From the log it’s apparent that several classes failed to compile:

LogBlueprint:Error: [compiler] Error Unable to find function with name MyFunction for Message node Invalid Message Node .
Warning Unable to find function with name 'MyFunction ’ for Invalid Message Node

I have a bunch of these and one of the failed classes is the pawn class so no wonder the standalone game burns.

Interestingly while some functions are not found, others are apparently fine because I don’t see an error for them. The function calls are done through an interface. I tried casting the output of GetGameState then directly accessing the functions but that broke the whole editor so badly that I had to restore the project from backup.

Branch: Binary
Build version: 4.4.0-2255576

EDIT: Casting the game state results in an editor crash on startup.

I tried the following: Let’s say the functions Apple, Banana and Cherry are having the aforementioned issue, they are not found for whatever reason. They are located in a custom gamestate class and called through an interface from all kind of classes.
Now in the interface I made a copy of Apple as Apple2 and in the custom gamestate class I removed the Apple event and replaced it with Apple2. I compiled them both.
In all other classes I replaced calls to Apple with Apple2 and did not compile the changed classes in the editor. Instead I just quit and restarted the editor. Started a standalone game which crashed but in the log all errors regarding Apple were gone.
I thought I had found a workaround however it’s not the case. As I worked my way through the rest of the functions (Banana and Cherry) at some point Apple2 popped up as not found… I did everything again with Apple3 but then Banana2 broke and so on…
Manually compiling changed classes in the editor instantly brakes a handful of other (not seen before) functions.

Interestingly cooking is successful and packaging the project creates an executable which runs fine. Maybe the problem is with the way a standalone game is created in the editor?

This issue just started happening to me. I noticed several errors in the logs saying it couldn’t compile Blueprint XXX. I noticed that all the functions it was complaining about were functions defined on Blueprint YYY. Blueprint YYY also refers to Blueprint XXX. So, it was a 2 blueprints that reference each other. I have plenty of other cases like this, so I didn’t expect there to be a problem. And things work when PIE and Launching. It’s just StandAlone that fails.

So, to appease the finicky StandAlone, I made an interface ZZZ, which Blueprint YYY now implements and I made Blueprint XXX only have references to interface ZZZ.

The compile errors went away and my project is no longer broken.

Hopefully this helps you.

It is a decent hackfix for the short term. I won’t mark it as a solution tho as this issue should be fixed properly.

Still not fixed. The hackfix works though.


Some months later I’m having the same problem as CombatJack.

Seems like this error first occured when I renamed a function, which is called from another blueprint.
I might try what CombatJack suggested, however maybe by now someone has a proper fix for this issue?

My Function was called ShowMenuHUD, but i renamed it to ShowHUD.
It is inside MyPlayerController and is called from lots of other blueprints.
The DebugLog only says that ShowMenuHUD doesn’t exist (which makes sense as it is now called ShowHUD).

I’ve manually gone trough all my Blueprints looking for the ShowHUD being called instead of ShowMenuHUD, and everything seems correct.
In PIE and Standalone everything seems to work as intended (Calling ShowHUD), only when I try to Launch my Project this happens.