Unable to extract UE4 install from zip file

I tried downloading Unreal Engine from unrealengine.com and I cannot extract the install file (.exe) to any folder. I’ve tried downloads and desktop. The zip file shows up as empty but the properties window shows that there is 35.1 megs of info. I am running Windows 10

I think you should be able to run the installation without extracting anything, just double click the EpicGamesLauncherInstaller.msi file, and click run, and it should work.

I’m not sure that I understand…

The installation file downloaded from unreal shouldn’t need extracting. This page might explain it better:

My issue is that even when I double click the .msi file, I don’t get a “Run” option, just an empty zip file…

Oh ok. Hmm, then it sounds like there might be an issue with being able to run .msi files. I’m not sure how to fix that. My apologies…

No worries, now that I know it could be an msi issue, there’s a couple different ttoubleshoots I can try out. I’ll post my findings if I’m successful

Ok, so what I’ve tried so far is redirecting my “Temp” and “Tmp” folders to my C drive root folder. I’ve also tried enabling my windows installer and adding " -OpenGL" to the file path in the EpicGamesLauncher shortcut. I’m thinking now, i need a specific app to open the .exe file and its just a matter finding that app unless someone on this forum already knows which one I need.

Hey vortega92-

Clicking GetUnreal from the unrealengine.com website and choosing a platform should initiate a download of a “EpicGamesLauncherInstaller.msi” file. Can you let me know what the exact file/folder name that downloaded when you went to unrealengine.com was?


I tried downloading both from the “Get Unreal” button on the home page and the “Choose your platform” option

That is the correct file, you should be able to run that (by double clicking on it) from your download folder. It will start the install process for the Launcher and allow you to decide where you want the Launcher and eventual engine versions saved on your computer. Let me know what happens when you double click on the .msi file and what else you’ve tried to install.

Ok, figured out the issue: the computer was trying to open the .msi file with Mega Zipper, so I just uninstalled Mega Zipper, re-downloaded the file and opened it with Windows Installer. Kinda figured it was something simple like that.