Unable to download unreal engine

the launcher is unusable, only opens half the time, when it does decide to open it will hang on please wait for ages, after about 5 hours of trying it got into the launcher about twice and then none of the buttons worked so i couldn’t download the engine. tried every single method on any of the forums, wininet, opengl, tried re downloading reinstalling nothing is working, is there not a way i can just download the engine without the launcher

Have you tried to start the Launcher using Administrator?

I just fixed the issue with following steps:

  • Run the launcher as administrator
  • Disconnect internet once its opened
  • Change your dns to google dns or any other dns (if its not already set)
  • Reconnect and click resume.

Hope this works for you as well.

Hi Liam Anderson,

I’m sorry that you are having an issue with the Epic Games Launcher. In order for us to offer the best support, we have recently modified the process for how Epic Games can help troubleshoot your Launcher issue. Please visit http://help.epicgames.com/ for technical support, here you can find information and solutions for common issues, as well as a contact form if you still need additional assistance. Thanks!