Unable to download/repair UE4.26.2

Trying to repair my version of Unreal Engine 4.26.2
Keep getting this. I know my internet is working because I just installed Unreal Engine 5.0.2 in another system on the same network.


Is it a problem with the Epic Launcher?

If you have an internet connection it’s most likely due to the launcher or their internal servers. Have you tried to relaunch the Epic Launcher?

Yes I’ve tried relaunching and restarting the PC. Still unable.

EDIT: Reinstalled/Repaired the Epic Launcher. Still unable

Would you mind if I ask where you are from? Perhaps your location has a more troublesome connection? Perhaps a VPN or something like this may cause issues when installing?

Pakistan. This is an issue with system I think. Because I just installed UE 5 on another system on the same network

@Amanda.Schade I’m unable to post new questions to the forum, only able to reply to existing ones. Getting the “you are not permitted to view the requested resource” error. Pls halp