Download

Unable to Download GitHub Unreal Engine 4 Source Code (v 4.8)

Hi, I’ve been attempting to clone UE4 source code to my PC but it says, “Failed to Clone Repository. The process timed out. The repository is in an unknown state and likely corrupted. Try deleting it and cloning again”. This happened twice now. I would get to around 20% complete or something and it would happen.

Download the Source as a .zip?

I’m getting continual network errors doing both.

Hey Icaraeus-

At what point are you getting this error message? If this is happening when downloading the .zip file, also try using another branch (4.7 branch) and see if you can down load the .zip for that branch. If you are able to download the .zip file for the 4.8 branch are you seeing this error when running Setup.bat or GenerateProjectFiles.bat?

Cheers

Doug

Hi Doug,

This is happening during the downloading of the .zip file. I haven’t attempted to download the 4.7 branch yet, I might give that a try.

I managed to download the zip file, but the download speed is agonizingly slow… max at 20kb/second (the same thing with git clone). I tried other websites - I can easily get download speed of 500kb/sec.

How fast is you’re internet? (Also being in malaysia might be the problem. :frowning: )

hah you should see my Internet. 130kb/s at best.

I lived in Malaysia for a few years and some sites had the same problem for us :frowning:

I get around 45kb/s at best. Who has internet that bad? Me. :frowning:

I live in Los Angles. And my internet sucks!

Still can’t download source code :frowning:

Hey Icaraeus,

What OS are you running on and how are you attempting to download the source (downloadable .zip, cloning process, etc)? Were you able to try downloading the 4.7 branch or did you get the same error message?

Hi Doug,

I’m running Windows 10 Professional Insider Preview Build 10130. I attempted to clone the source and download it as a .zip, but same error applies. Same goes for the v4.7 branch.

Same here. The download .zip option is slow, and I feel back to the 90´s having to download something at 20kb/s, specially when I can download everything else at 1-2mb/s. At least to me, github sucks big time when it comes to speed.