Unable to deploy on iOS devices in 4.13.1


Previously I was able to deploy my prototype games on iPad, iPhone 5 but when I have upgraded to 4.13 I got this strange error. I’m running UE4 on windows 10.

Here’s the log:

Running AutomationTool...
Automation.ParseCommandLine: Parsing command line: -ScriptsForProject="C:/Users/Orange/Documents/Unreal Projects/mobiletest3/mobiletest3.uproject" BuildCookRun -project="C:/Users/Orange/Documents/Unreal Projects/mobiletest3/mobiletest3.uproject" -noP4 -clientconfig=Development -serverconfig=Development -nocompile -nocompileeditor -installed -ue4exe=UE4Editor-Cmd.exe -utf8output -platform=IOS -cookonthefly -nokill -map= -compressed -stage -deploy -cmdline=" -Messaging" -device=IOS@All_iOS_On_ZOMMEOW -addcmdline="-SessionId=AEA301F4401ACBBEF56DEFBA2E293F1D -SessionOwner='Orange' -SessionName='All_iOS_On_ZOMMEOW' " -run
Automation.Process: Setting up command environment.
BuildCookRun.SetupParams: Setting up ProjectParams for C:\Users\Orange\Documents\Unreal Projects\mobiletest3\mobiletest3.uproject
Project.Cook: ********** COOK COMMAND STARTED **********
CommandUtils.Run: Run: C:\Program Files\Epic Games\4.13\Engine\Binaries\Win64\UE4Editor.exe "C:\Users\Orange\Documents\Unreal Projects\mobiletest3\mobiletest3.uproject" -run=cook -cookonthefly -unattended -CrashForUAT -FORCELOGFLUSH -log -abslog="C:\Users\Orange\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+4.13\Server.log" -SessionId=AEA301F4401ACBBEF56DEFBA2E293F1D -SessionOwner="Orange" -SessionName="All_iOS_On_ZOMMEOW"
Project.Cook: Waiting a few seconds for the server to start...
Project.Cook: ********** COOK COMMAND COMPLETED **********
Project.CopyBuildToStagingDirectory: ********** STAGE COMMAND STARTED **********
Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Stage Failed. Missing receipt 'mobiletest3.target'. Check that this target has been built.
   at Project.CreateDeploymentContext(ProjectParams Params, Boolean InDedicatedServer, Boolean DoCleanStage)
   at Project.CopyBuildToStagingDirectory(ProjectParams Params)
   at BuildCookRun.DoBuildCookRun(ProjectParams Params)
   at AutomationTool.BuildCommand.Execute()
   at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
   at AutomationTool.Automation.Process(String[] Arguments)
   at AutomationTool.Program.MainProc(Object Param)
   at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
   at AutomationTool.Program.Main()
Program.Main: AutomationTool exiting with ExitCode=103 (Error_MissingExecutable)

Also when I looked at packaging results I get this error

PackagingResults:Error: Error Remote compiling requires a server name.  Please specify one in the Remote Server Name settings field.  

Even though I have never stated any server info in the Remote Build Options input field.

I have also looked into similar problems on the forums. And I have already done these:

  1. Installed the latest iTunes.
  2. Installed the latest VS2015 common tools (Someone suggested this in a different forum)
  3. iOS Certificates and provision are valid and installed.
  4. Bundle Identifier is correct.

How to reproduce:

  1. Create a fresh top down blueprint template
  2. Launch on iOS

Help would be greatly appreciated!


Hi malevolent,

Other solutions posted to the error you are seeing:

  • Package your game first. “packaging your game will generate the missing receipt file, allowing you to cook.”
  • Disable the Substance plug in if enabled
  • If you are on a PC, make sure you do not have any C++ elements in your game as these will have to be compiled in XCode on a Mac in order to Launch on to an iOS Device
  • Do not check any boxes under Project Settings>iOS>Certificates and Provisions; Instead allow UE4.13.1 to choose automatically (DO fill in correct Bundle Identifier, however)

Let me know if none of these resolve your issue and whether you’re on a PC or a Mac.

Steve H.

Hi Steve,

Thank you so much for your help! Unfortunately it still doesn’t work.

  • I tried to package my game. but I get this error

    LogPlayLevel: UnrealBuildTool: Picking the default remote server
    LogPlayLevel: UnrealBuildTool: Remote compiling requires a server name. Use the editor (Project Settings, IOS) to set up your remote compilation settings.
    LogPlayLevel: UnrealBuildTool: Doing xcode-select --print-path
    LogPlayLevel: UnrealBuildTool: ERROR: Failed to start local process for action (“Cannot start process because a file name has not been provided.”): -o BatchMode=yes ${CURRENT_USER}@ “cd “/” && xcode-select --print-path”
    LogPlayLevel: CommandUtils.Run: Run: Took 0.932887s to run UnrealBuildTool.exe, ExitCode=5
    LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.CommandUtils+CommandFailedException: Command failed (Result:5): C:\Program Files\Epic Games\4.13\Engine\Binaries\DotNET\UnrealBuildTool.exe mobtestt2 IOS Development -Project=“C:\Users\orange\Documents\Unreal Projects\mobtestt2\mobtestt2.uproject” “C:\Users\orange
    Documents\Unreal Projects\mobtestt2\mobtestt2.uproject” -remoteini=“C:\Users\orange\Documents\Unreal Projects\mobtestt2” -noxge -generatemanifest -NoHotReload. See logfile for details: ‘UnrealBuildTool-2016.10.16-00.20.29.txt’

  • I don’t have Substance plug-in installed. I just rechecked and made sure that I don’t have it.

  • There’s no C++ elements in my project.

  • I just removed all the check boxes under certificates and provisions that you have mentioned.

The strange thing is, why does it ask for a remote server to build? I haven’t specify any remote server info.

Anything else that I need to try?

I was not able to reproduce this following your repro steps…

As for the server error, asks for a remote server build due to cooking on the fly, but typically this is not a problem and is not the error pictured in the Screen Capture of your Project Launcher.

I looked at some more issues similar to this… The error being displayed is that it is “missing the receipt target” and then lists your project’s name. Hence, I suggest the following:

  1. Make sure your device is plugged in and recognized and visible in the Device Manager
  2. Delete your Intermediate and Saved folders
  3. Try with this selected and unselected:

  1. Make sure your game is set in these fields:

  1. Make sure Under Projects>Packaging> set for “Development”

Try these and post a screenshot of the error in the Project Launcher as well as the entire text from the Output Log if it fails to Launch on your iOS Device.

I’m curious about 1. How to check whether my device is visible in the device manager? Please see the screenshot I have given. On my iTunes from this machine I can see my device just fine.

For number 2 - 7 I tried but they gave the same error.

I will try it again tomorrow and I will post the log.


Please disregard step one, I’ve tested this by Launching on one of our iPads and the device did not show up in the Device Manager -just be sure it is recognized in iTunes.

Since I’ve been working on this post, I’ve run across a few more posts that may be related to your issue and have been working to identify the root of the problem. Please post your entire output log when you try to package again following the other previously posted steps -thanks.

link text
link text
link text
link text

Please find the logs in this post.

As a test:

  1. Try packaging or launching on to an iOS device a blank Third Person Blueprint Only project making sure are plugins are disabled…
  2. Try packaging or launching on to an iOS device your project making sure are plugins are disabled.

If one or both fail, post only the log of the one(s) that fail. (An active plugin may be causing your project to try and build remotely.)

Ok! after disabling the plugin, it worked! I’m using Dungeon Architect plugin that I bought last week. Thank you for getting to the bottom of this.

Which version and when would this bug be fixed? I will need to use this plugin for my project.

Hi malevolent,

This is not a bug. If you use code in your project, which is what you are doing when you introduced the Dungeon Architect plugin last week, you will need a Mac to compile the C++ code in XCode so that it is “translated” for iOS devices. This step is not needed for Blueprint only projects, which is why you could Launch On devices before.

At this point, if must use the plugin, you will have build remotely on a Mac.

Steve H.