Unable to debug in Visual Studio


I am trying to debug my C++ code in VS 2013 by pressing F5, but it gets error:


I use UE 4.8.1, downloaded from Launcher, project created in UE 4.7.

Where I can change settings of the path ‘C:\Program Files\Epic Games\4.8\Engine\Intermediate\Build\Unused\UE4.exe’?

Thank you.

What cyrillic text means?

Can’t find file.

That’s right, because it trying to find 'C:\Program Files\Epic Games\4.8\Engine\Intermediate\Build\Unused\UE4.exe. There are no UE4.exe in C:\Program Files\Epic Games\4.8\Engine\Intermediate\Build\Unused .

Only UE4.txt.






Errors of this kind usually occur when during attempts to run UE4 project instead of your game project through the Visual Studio debugger.

Please note that this won’t work with the Launcher version of the Engine.

However, you can right-click on your game project in the solution explorer and select the Debug → Start new instance option to debug it.

You can also set your project as default in Visual Studio (for this, please right-click on your game project and select “Set as Startup Project” option). Thus, when you press F5, the Visual Studio debugger will run your project instead of UE4 one.

If you want to be able to debug UE4 solution, you should build the Engine from source code, which can be obtained from GitHub repository (if you like to learn more about this, please go here:

Downloading Unreal Engine Source Code | Unreal Engine 5.2 Documentation)

Hope this helped!

Good luck!

Thank you very much!