Unable to create project files for 4.8 preview 3

I have a problem updating my project to 4.8 preview 3. I haven’t tested preview 1 or preview 2 so I cannot tell if the problem is specific to preview 3:

When I try to generate the new project files for version 4.8 via the windows right click context menu I get the following error message:

Running F:/Programme/Unreal Engine/4.8/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“F:/Unreal_Projects/Unreal_Space/Unreal_Space.uproject” -game -rocket -progress
Discovering modules, targets and source code for game…
UnrealBuildTool Exception: ERROR: Failed to create temporary batch file to harvest environment variables (“ERROR: Unable to convert path C:\Programme\Microsoft Visual Studio 12.0\Common7\Tools../…/VC/bin/x86_amd64/vcvarsx86_amd64.bat to 8.3 format”)

Generating project files for engine version 4.7 and 4.6 works fine so I don’t think there is a problem with the environment variables.

Can anyone help with that?

Hi ,

I attempted taking a project that was made in 4.7.6 and converting it to 4.8 Preview 3 without any issues. Is this only happening on one project or can you get this to happen with multiple, such as a brand new project? Also, what version are you converting from? I’ll need this information to assist you further this with this issue.

Thank you for the quick answer.

I tried several projects. All of them version 4.7. I can switch the engine version back and forth between version 4.7 and 4.6. Only 4.8 does not work.

This is also the case for freshly created projects. If I try to create a 4.8 project, the project creation fails with the same error.

If that is the case, something may of gone wrong with the installation. Can you try uninstalling and reinstalling 4.8 Preview 3? If this doesn’t fix the issue, I’ll continue to assist you, but it would be best to get the most simple solutions out of the way first.

I reinstalled 4.8. This time preview 4 since it was just released. Unfortunatly, the error persists.

Ok, was worth a shot. Up next, can you get your launcher logs? You can see how to do that at the following link.

Other than that, since it may take some time to find out why exactly this is happening by looking at the logs, can you try downloading the source version of 4.8 through Github and seeing if that will work for you? The link below can explain how to do this:

I attached the logs written while I was trying to create a new project. I briefly looked through the log file but saw nothing related to the failed attempt. However, I might have looked at the wrong places. I tried to create a project two times while logging was active.
link text

I will try building from source but it might take a while to set everything up.

This is completely a shot in the dark, but can you try running the editor in administrative mode? Seems some things aren’t being loaded and it could be related, according the log is isn’t being ran with the rights enabled.

It did not work. I attached the launcher log from the most recent try.link text

I tried generating the project files to build from source and got the same error message.

According to your launcher logs, it doesn’t seem like anything is wrong there.

What exactly happens when you try to create a new project on 4.8? What steps do you take and how far do you get before it gives you an error? Does the editor crash? If so I’ll need you to give me your crash logs. You can find out how to get those by reading the information at this link: A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums

I don’t even get to the editor.

After I select the name of the project and press ‘create’ a few directories and files are created. But at the point where usually VS should open I get a small error notification window with the message shown in the first post.

I can successfully create a blueprint project and start the editor but as soon as I add code to the project the project file generation fails again.

If they might be useful, I can upload the editor logs from a created blueprint project.

If I am understanding you correctly, you’re able to create projects based off blueprints, but not able to create projects that are C++ based? I was under the impression that you weren’t able to create any at all. This could narrow down the issue a lot if so.

Edit: Well, just re-read and that is obviously the case. At least now I have a frame of reference of where the issue is happening.

Edit 2: Should have a possible fix shortly

Try merging this into your source version of the editor:
You can either manually do the merge by removing/adding the specified code or you can merge it using Github. After that, try compiling and see if it’ll work. It will take some time to compile however as this will be compiling the entire editor.

Great, generating the project files for the source version is now working. Thank you very much.

Is there also a way to make this work for my existing projects?

This will be eventually integrated into one of the new versions of the editor, but for now, using the source version of the editor will be the only workaround. You may be able to convert your projects over, but be sure to make a copy first just in case they’re not compatible.

I’m having the same problem as where I can successfully create blueprint projects but c++ projects give me a compile error before it even creates them. I would try the fix you suggested but github is giving me 404.

If the Github link gives you a 404, this means you’re not signed into your Github account. Try signing in and then clicking the Github link.