Unable to create project because the project's name contains an invalid character

I purchased a project from Marketplace but have been unable to download it because of an invalid character error.

The project’s name is: “Real dynamic water - Create lake, river, pool, any you want”
It’s available here: https://www.unrealengine.com/marketplace/en-US/slug/real-dynamic-water-create-lake-river-pool-any-you-want

In the Epic Games Launcher, when I go to Unreal Engine > Library > Vault and try to download / create the project, I get a red error message telling me:
“Project names may not contain the following characters: -”

Unfortunately, the auto-generated directory path being created, which is based on the name of the Marketplace asset and thus includes the invalid hyphen “-” character isn’t something I can modify. I can change the parent directory, but not the lowest level directory which is the problem, because that’s being auto-generated by the Epic Games Launcher. This is happening on both Windows 7 and Windows 10.

The net effect is that it now seems to be impossible for me to download this asset from the Marketplace. Is there some way to download assets other than through the Epic Games Launcher, or some way to change the default directory name that gets created so it’s not something invalid?

Hey @iandallas

Have you tried submitting a support email to the seller directly? From what we can tell numerous users have downloaded the product but this is the first report we have seen like this.

If you are still unable to download the product, please submit a support case to us and we will investigate further: https://marketplacehelp.epicgames.com

FWIW, it turns out the problem isn’t isolated to this particular seller – it’s happening for any project I’ve tried to download that’s got a hyphen in its name and only has the “Create Project” option available. Strange that nobody else is encountering it.

I’ll go ahead and submit a support case.

You can change the default name given at the Project Creation UI for both project Name and project Folder, those fields are editable. Once you do that, the project can be created.


I’m having exactly the same problem. Downloaded and installed the latest Windows 10, yesterday (2019-10-19), along with the latest everything else. There is no way to rename the project when you click the “Create Project” button. All you can do is name the parent folder into which the pre-named project (with inadmissible characters) should be installed. So yes, this is kind of a big issue and no, it has not been resolved in this thread.

Same issue - there is not a way to rename the target project it wants to create. Those packages with a dash in their name cannot be accessed now at all.

This is version 10.8.2 of the Epic Launcher

On the choose location i clicked on the name of the folder that was about to be created,and deleted. So simple that it was confusing eheh!!

Hi! just don’t create spaces between the letters of the project name :slight_smile: that’s all

Still have this problem in several items from the official marketplace. Filename and folders so It doesn’t happen “ART,Fashion,AutomotiveGal”

There is quick solution to this problem. Click on “Create Project” button> Click on Name “Project-Name” a remove invalid characters. I know it may not look like you can change the name, but it is editable field.

Best of luck!