Unable to create good UV lightmap

Hi guys, I’m near to madness wih the Lightmap creation with Max2015, this is not the first project that I’ve made in Unreal and till now all was without too many troubles, but now nothing seems to work.

I spent two days testing out different kind on UV mapping (different padding, making the chunk boundaries square to fit the grid…but nothing works).
Does anybody can help me? (the file is attached), what am I doing wrong?


No, it isnt :stuck_out_tongue:

Can you post an image of the UV and the lightmap?

Don’t know why the files weren’t attached (I put the Unreal output in my previous post)
this is the UV disposition


How can I add the model?!?!? :confused:

Unless the mesh is actually rectangular then it’s not worth going through the trouble of matching it up to the pixels.
With UV mapping you need to do as much as you can to avoid seams, depending on what your UV’s are there’s probably ways to avoid that issue, like for instance that side of the door can be a single UV island.

I’m really getting lot confused: some tutorials teachs that more chunks is better, some other the opposite…when one and when the other?!?

this is the result leaving the whole door (except for the doorhandle) as one single mesh, still dosen’t work :frowning: How can I share the 3D model so someone can try?

From that UV image, the inside of the door handle needs to be attached to the main door panel, there’s no need to separate it, that alone will probably fix the issue.
other things–there’s some small pieces and slivers which probably don’t need to be separated, the door handle should be the main thing that’s separate. Also, in UE4 make sure your static mesh resolution is high enough, if it’s too low then the empty space will bleed over on the mesh.

I have just tried to have a single mesh (except for the handle) doesn’t work the same, increasing the resolution don’t solve nothing :(.

Here is the link for the model of the door (3dsmax2015, if needed I can send an FBX)

upload a .obj

here is the link, fbx and obj:


You need to map it like this–the fewest seams as possible, and there’s no way for the door handle part to bleed in the wrong place.


Just tested as you suggested and did not worked, you tried to import the mesh into Unreal and see the result?

Open the static mesh properties, my guess is that your lightmap resolution is the default and that you changed it in the wrong place, the default is usually too low.

tired both ways, by enabling the “override lightmap resolution” on the “lighting” tab or directly changing the resolution into the static mesh settings…no better result :frowning: