Download

Unable to create C++ projects

Hello! I’ve been trying to follow along with the battery collector thing for like a month now, but each time I try to create a project, gives me an error.
The first time I tried it, it was successful, and I got all the way to creating the floor thing, and then it wouldn’t compile and asked me to install SDK for Win 10. So I did, but it wouldn’t compile anyways.
I restarted the computer, deleted the project to start fresh. It gave me the same error. Installed win 8.1 SDK, same error. Left it for a week or two, reinstalled some drivers (for other reasons), updated windows, came back to it again.
Today, I got this error:


The project could not be compiled. Would you like to open it in Visual Studio?

Running C:/Epic/UE_4.18/Engine/Binaries/DotNET/UnrealBuildTool.exe BatteryCollector Development Win64 -project="F:/Documents/Unreal Projects/BatteryCollector/BatteryCollector.uproject" -editorrecompile -progress -NoHotReloadFromIDE
Creating makefile for BatteryCollector (no existing makefile)
Performing full C++ include scan (no include cache file)
@progress push 5%
Parsing headers for BatteryCollectorEditor
  Running UnrealHeaderTool "F:\Documents\Unreal Projects\BatteryCollector\BatteryCollector.uproject" "F:\Documents\Unreal Projects\BatteryCollector\Intermediate\Build\Win64\BatteryCollectorEditor\Development\BatteryCollectorEditor.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -installed
Reflection code generated for BatteryCollectorEditor in 23.7269848 seconds
@progress pop
ERROR: No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe



I’m getting really, really frustrated and I don’t know what to do anymore. I’m only trying to follow the tutorial and I can’t even create a C++ project (blueprint projects are mostly fine). Any help would be greatly, greatly appreciated.

Looks like you don’t have all needed components for Visual Studio.

https://docs.unrealengine.com/portals/0/images/Programming/Development/VisualStudioSetup/VS2017_SettingsNoInstaller.png

When you install VS do you have everything ticked as shown in the image? Also you might want to compile the project in visual studio once before trying to open it directly.