Unable to configure gradle, gradlew, android. Cannot build without configuration

Im starting to notice the Android implementation for Unreal is very poor. I can’t build through the generated batch file which is calling gradlew (not sure why they don’t just execute gradlew). Either way, gradle is using JAVA_HOME as an environment variable. I am unable to change this on a system level due to every other project I work on using higher than J8. For this reason, I’ve tried to add

org.gradle.java.home=C:\Program Files\Java\jdk1.8.0_281

Into the gradle.properties (it’s in the generated intermediate folder) so it gets overwritten. Basically what it means is I’m unable to configure my project unless it’s in Unreal’s project settings. I had a look there, there is no options to actually configure the gradle version, wrapper distro url, local properties, gradle properties…

Is there any way I can force unreal to use a different gradle wrapper with my own gradle properties? One size does not fit all environments, would save me hours of time if I could actually configure my projects.