Unable to complete GenerateProjectFiles.bat

I’ve cloned the release version from GitHub with VS 2015. I’ve successfuly compiled the engine on my old laptop(one week ago) using VS 13. When i start Setup.bat everything is fine. When i start GenerateProjectFiles.bat this message appears in the cmd window:
Setting up Unreal Engine 4 project files…

GenerateProjectFiles ERROR: We couldn't find a valid installation of Visual Studio.  This program requires Visual Studio 2015 or Visual Studio 2013 or Visual Studio 2012.  Please check that you have Visual Studio installed, then verify that the HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\14.0\InstallDir (or HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\14.0\InstallDir on 32-bit machines) registry value is set.  Visual Studio configures this value when it is installed, and this program expects it to be set to the '\Common7\IDE\' sub-folder under a valid Visual Studio installation directory.

Press any key to continue . . .

Hey radibg2-

When you cloned the release branch did you use the Git client or did you download the .zip file and extract the content to your computer. Are you able to download the zip file for the 4.9 branch and run Setup.bat and GenerateProjectFiles.bat there? If that also gives you errors you may need to reinstall Visual Studio.


Hi, i’ve cloned it with the integraed git client in VS 2015. I’ve downloaded the zip, reinstalled VS and again the same error when i open GenerateProjectFiles.bat.

If you run from the zip and still have errors with the GenerateProjectFiles.bat file then you should try ensuring that the batch file is reading your VS 2015 properly. This can be done by navigating to the engine folder then, with no items in the folder selected, use Shift + right click and selecting “Open Command Window Here”. In the cmd window that opens you can enter “GenerateProjectFiles.bat -2015” which should run the batch file with the 2015 compiler.


The same error appears.

There are a few more questions I’d like to ask to get a better understanding of what’s happening. Is VS2015 the only version of Visual Studio on the machine currently? If so, does the problem occur after installing VS2013? Are Visual Studio and Unreal Engine on the same drive on the computer? What is the path for VS and UE? If there are any special characters in the path you may need to rename the path folders or move the programs to a different location. It may also help to check that the path variables are set appropriately. Here are a couple of other posts with the same issue (couldn’t find valid VS install) along with how they were able to solve the issue by editing the path variables:

Let me know if either of these helps

I don’t have any other version of Visual Studio than Community 2015. I don’t want to compile it with VS 2013, VS 2015 is supported now so i am trying to compile it with it. VS 2015 is on my SSD, the UE4 is on my HDD(they are on different partitions). The path of UE4 is D:\UnrealEngine, the path of VS is C:\Program Files (x86)\Microsoft Visual Studio 14.0. I don’t have any special symbols in the paths like & so the first suggestion is not an option. Also i don’t have second declaration for system 32, edited C:\Windows\system32; to C:\Windows\system32; but the result is the same, so neither of you suggestions worked.

I’ve installed the compiled version and it asked me to check if i have installed Windows SDK and Visual Studio Toolchain. I’ve clicked repair on VS 2015 from Uninstall programs and installed them and the error disappeared.

Hi bro, which version u use , community or professional version ?