Unable to compile in 4.17


[edit] : Every time I try to compile any project !
There is always this error :

UATHelper: Packaging (Windows (64-bit)): Running AutomationTool…
UATHelper: Packaging (Windows (64-bit)): Automation.ParseCommandLine: Parsing command line: -ScriptsForProject=“U:/HouseTree 4.17/HouseTree.uproject” BuildCookRun -nocompile -nocompileeditor -installed -nop4 -project=“U:/HouseTree 4.17/HouseTree.uproject” -cook -stage -archive -archivedirectory=C:/Users/XXX/Desktop/VR -package -clientconfig=Development -ue
4exe=UE4Editor-Cmd.exe -pak -prereqs -nodebuginfo -targetplatform=Win64 -build -utf8output
UATHelper: Packaging (Windows (64-bit)): XmlConfigFile.TryRead: ERROR: ‘.’, hexadecimal value 0x00, is an invalid character. Line 1, position 1.
UATHelper: Packaging (Windows (64-bit)): Automation.Process: Failed to initialize UBT
UATHelper: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)
UATHelper: Packaging (Windows (64-bit)): BUILD FAILED
PackagingResults: Error: Unknown Error*

nothing else, I dont use any 3rd party plugins whatsoever.
Any suggestions ?

Anything ?

I had tried to re-install the engine and the issue persists.
Since it is happening even on empty project, I had ruled out any issue with “saved” directory etc.

I was having the same issue, but here’s your answer :stuck_out_tongue:

VS2015 Update 3 Required

A fundamental C++ change:

Visual Studio 2015 Update 3 is now required to compile UE4 on Windows.
Proceed Carefully, getting 2015 Update 3 will break engine versions older than 4.11

Thanks for the info, I had applied the update 3 for VS2015, however the issue still persists.

Have you tried compiling on an empty project to see if you produce the same error? Post back the error if it happens!

Yes, I had tried an empty project and it still failed.
However, I had uninstalled 4.17 and installed it again, after the patch of VS and all seems to work and all projects compile.

Thank you very much for the help, now I can enjoy the new features of 4.17.
For anyone who will have the same issue, the exact link for download is here :
microsoft dowload link

Ah yeah, I figured out what the issue was when I decided to actually look at the log. It turns out that you were trying to actually package the project, so that’s definitely my bad for not looking out well enough lol.

After 4 days of bug testing, and 4 reinstalls of windows, I found out that the cause was this file:
My Documents\Unreal Engine\UnrealBuildTool\BuildConfiguration.xml

It was empty, and Ue4 was trying to use it instead of the default location of the Build Configuration.

Deleting it is the solution.