Unable to compile fresh branch 4.18 clone

I forked and cloned the 4.18 branch and am trying to build it, but I’m getting the following two errors:

Error    C2039    'MergeShaderCacheFiles': is not a member of 'FShaderCache'    ShaderCacheTool    C:\Users\\Documents\Git\UnrealEngine\Engine\Source\Programs\Mac\ShaderCacheTool\Private\ShaderCacheTool.cpp    66

Error    C1083    Cannot open include file: 'Interfaces/IAutomationWorkerModule.h': No such file or directory    BuildPatchTool    C:\Users\\Documents\Git\UnrealEngine\Engine\Source\Programs\BuildPatchTool\Private\ToolModes\AutomationMode.cpp    12

Any clues as to why this showing up

I’m building the Developer Editor for Win64.
When using Setup.bat, this was my command line: -exclude=PS4 -exclude=XboxOne -exclude=Switch -exclude=Dingo

The 4.18 branch is work in progress. It probably doesn’t compile.

You could still try running setup.bat without those parameters, the platform exclusion thing… generally doesn’t work. There’s a big topic on that somewhere that I can’t find.

Tag 4.18.0-Preview-3/4 doesn’t compile either, same two errors. I’ve also looked through the code, “FShaderCache::MergeShaderCacheFiles” doesn’t exist.

Are you maybe trying to build the entire solution? You will rarely need more than UE4, UnrealFrontend, UnrealLightmass. That ShaderCacheTool does seem to be broken but there’s no reason to build it on windows.

Is there a description somewhere about what each module is for so I can pick out what I want to compile?


I was getting the same error when I tried to build UE 4.18 release on Windows 10 Home x64 with Visual Studio 2017 v15.4.1
I tried to clean the solution and build again. . .but it failed.

Then I restarted Visual Studio as Administrator user privileges and did a rebuild.
It works !

Hope this helps.

Is 4.18 compiling with visual studio 2015 update 1?