Download

Unable to change the hairworks settings in UE4

Hi. I managed to build UE4 code from github. I also created a grass using nvidia Hairworks and imported it successfuly to UE4. Then, I created a blueprint actor and inserted the hairworks file which I just imported. Finally, I put it on the scene where everything looks fine. However, it is not possible to change to settings of hairworks. They are visible, but the inputs are disabled. Could you tell me why and how to resolve this problem. Thanks in advance.
P.S.: Greetings from Slovakia, love you guys, making UE free made my dreams come true :slight_smile:

Hi. I have moved your thread to the relevant section.

Hey panthersdecacahouete ,

I think there might be couple of ways you could do that,

  1. Once you have created the blueprint as the samples, Select the HairWorks component. Then in the ‘Details’ section there is a subsection ‘Asset’ there you will find an ‘Override’ checkbox. This is enable editing for the Hairworks attributes.

  2. One other way which has not worked for me consistently is opening the double-clicking the hairworks asset and changing attributes over there, once the changes are done, saving should ideally reflect those changes in the main blueprint.

Let know if any of these methods works for you.

Hi panthersdecacahouete & aKS,

Overriding the hairworks asset in the blueprint gave me problems with saving, the changes I made did not save properly and there were some issues with collisions. I found that making changes directly on the asset (double clicking the hairworks asset in the content browser) was more stable in that regard. BUT, I seem to be having problems with certain fields such as strand width and density not updating??? Let me know if anyone has also found this or has any suggestions.

p.s. I’m using control maps for most variables.