Unable to build project file


i am having issues with building my project.

I use win7, visual studio 2013 Ultimate, UE4 4.3 Launcher version.

Visual Studio 2013 is installed on C:
The Engine is installed on D:

When i start a new project from out of the engine everything works fine, i can add code, build etc. no problem.

But when i try to build the already existing project (download from SVN on D:) i can launch the editor but the solution is unable to build.

I am getting the following errors:

Inside Visual Studio:

System cant find path
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command ""D:\Apps\Unreal Engine\4.3\Engine\Build\BatchFiles\Build.bat" Projectname_BlankEditor Win64 DebugGame "D:\Apps\Unreal\Projectname_InDev\Projectname_Blank.uproject" -rocket" exited with code 3.

And when i right-click on the .uproject → Generate VS Project files i get:

Running D:/Program Files/Epic Games/4.3/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project="D:/Apps/Unreal/Projectname_InDev/Althas_Blank.uproject" -game -rocket -progress
Discovering modules, targets and source code for game...
ERROR: Exception thrown while processing dependent modules of SoundVisualizations
ERROR: Couldn't find module rules file for module 'Kiss_FFT'.

I explored the AnswerHUB finding different Questions for this, but those solutions described there wont work for me or were for the GitHUB version.

reinstalled VS as well as UE4 several time and still no progress.

Please help me

kind regards

Ok, i think i know what went wrong, inside the error:

1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command ""D:\Apps\Unreal Engine\4.3\Engine\Build\BatchFiles\Build.bat"

He is looking for Apps\Unreal Engine, i think this path comes out of the config of our svn trunk, because this path does not exist on my D: harddrive. I need to know how to change the path VS is looking for the Build Batch inside my installed Engine if im not mistaking it

please could you tell me how to do this?

Ok i think i got it now what went wrong. (Cost me 8 hours of lifetime)

The problem was that in our trunk the VS dependencies were set on an old pathing from unreal. F.e. it has the Folder Unreal Engine/4.x/… now i think during an update it is the Folder Epic Games/4.x/… so when building and searching for Batchfiles as well as libs etc… you have to change that in properties. Right click on Project inside Solution explorer → Properties. Click on NMake to the left. You can now check if the pathes shown under General are pointing correctly to where your batch files actually lie.
If its not, you can easily edit them there overwrite the wrong Path with the correct one.

If that was the issue, you have now the problem, that you need to change the path to all Includes/Libs as well.
And that is a hell of work doing that by hand.

So best would be for both cases to replace the static pathes through a variable.

Please dear Epic Team notice me how to do that in a proper way :slight_smile:

Hi ,

I am not sure what may have happened to change the path in the dependencies you are using. I did some checking and the names we are using in our current version are the same as they were back in 4.0.1:


If you change your folder back to Unreal Engine/4.x/ does that resolve the issue?


thank you for your response. Yes that solved the issue, i did that on my own.

I think the problem wasnt on your side but rather in our team, that somehow someone committed into trunk with this path config and though i wasnt able to build.

So the installer always tried to install into Program Files by default for me and for some reason the one who created our project has installed it in a folder called “Apps” which not existed on my Computer. However thats a guess, that the one who created the project committed his config too.

by the way: by default installation, the installer create a folder called “Epic Games” for me which was not the case when i installed UE4 for the first time a while ago. Though im certain to never created a folder called like that and checked that already in installing by default again.

This question can be marked as “Solved”

I get the same warning when I try to package a game with the SoundVisualiser plugin. Looking in the source code you see it requires the 3rd party module:
AddThirdPartyPrivateStaticDependencies(Target, “Kiss_FFT”);
But that module is not in my C:\Program Files\Unreal Engine\4.4\Engine\Binaries\ThirdParty directory.

Disabling the plugin solved it.