Unable to build AutomationTool on Ubuntu 16.04 LTS

There is a problem in the build script of the AutomationTool.
When i start up UnrealFrontEnd, after i built the engine, i try to cook and pack a project. The tool then tries to compile UAT, but fails because unresolved symbols. I solved this by building it myself by copying the command that was shown in the UnrealFrontEnd and pasting it in my terminal, then i added: /p:TargetFrameworkVersion=v4.5
Once the tool was built i had no longer problems.

Hey Joejoepie-

Do you have the same error trying to use File->PackageProject->Linux? What is the exact error message you received that mentioned the unresolved externals? If you are able to reproduce this in a new project, please include the steps used to setup the project?

Hi, yes this was the same result. And the errors i was getting was that UAT failed to build, and this was due to not finding System symbels, like Sytem.Object and System.Xml and the like.
It was on a french install of ubuntu 16.04.

I did come across a known issue with the Automation Tool for Linux. You can try incorporating the associated pull request (https://github.com/EpicGames/UnrealEngine/pull/2397/files) into your engine build to see if it solves the packaging issue you’re seeing. Let me know if you have further questions.

Cheers

Doug Wilson