Download

Unable to bake animations from Maya for UE4

Hi, I had made a game ready character and rigged and skinned him in Maya, a screenshot of the rig is attached.
I created an idle pose animation in the conventional way, by key-framing the spline controllers, then I exported it in fbx format, 2 files, one with simply the skeletal mesh, and the other with a loop idle state animation.

All the settings required to export animations were checked.
I even baked the animation keys by going under Edit>Keys>Bake Simulation.

Still when I import the files in UE4 and try to play the animation all I’m getting is a still posed mesh with only its hip bone moving up and down, which in turn is just moving the whole character up and down.
I’ve tried various ways to bake the animation but its still not working, here’s the range of attempts:

1- Selected the hip bone (master bone of hierarchy), selected the mesh, baked the animation. - DIDN’T WORK

2- Selected the controllers and the hip bone, baked animation. - DIDN’T WORK

3- Selected everything and baked. - DIDN’T WORK

for cross checking I opened each of these fbx in max,
and even there too the animations were not playing, what’s wrong in my approach, please help!

1.PNG.jpg

You don’t even need to bake the animation before you export, because usually the export itself will bake the animation into the skeleton.

Select your mesh, then select your root and go to modify>select hierarchy and then Export selection.
Ont the FBX export settings check if the animation tab is flagged…if not, flag it and set the timeline so that your animation can be exported.