Download

Unable to add materials in mesh editor

Hi all, at some point I lost the ability to add materials to every asset in the mesh editor. Dragging and dropping doesn’t work, nor does the drop down option. Any ideas how to fix this or what caused it? For the moment anything that didn’t already have a material on it before this happened, I’m having to manually add each material to in the level.

I’m using 4.24.0

Walk us through how you’re applying the material to the mesh and what the problem is. Do you get a red square around the material slot? Are you dragging it to the material slot and not on top of the object in the content browser?

I assume you’ve made a material and aren’t trying to apply a texture.

Thanks for the response, and apologies, attempted to upload a video but wouldn’t let me.

So,

  1. I’ll double click on a mesh in the content browser or from the details panel of one thats already in the level which opens the mesh editor window I think its called.
  2. Ill click and drag a material from the content browser that is already applied to dozens of assets in the level
  3. hover it over the material slot of the asset in the mesh editor and a green dashed box surrounds the material slot
  4. I release the LMB and nothing happens, the material thats already there remains. E.g- world grid material or one that was applied before this starting happening.
  5. Also unable to click on the drop down menu to choose a material.

Not sure if this will be of any use, but heres what it looks like.