UMG Unable to Create Template For Widget

After updating a project to 4.16, I found an error in the main HUD widget.

Unable to Create Template for Widget.

Fast Create Widget Warning! This class cannot be created using the fast path, because the property Hero2 on Master_GameHUD_Widget_C references Hero2. Please add the ‘Instanced’ flag to this property.

The only ‘Instanced’ flag I know of is the Instance Editable option in the variable settings. Changing this didn’t fix it so I’m not sure why it can’t be created.

I’m running into the same error, too and have no idea how to resolve it.

Yeah. I have a custom widget with a Named Slot in it. I then have an instance of that widget that I’m dragging buttons (other custom widgets) into (using the UMG UI - they’re not being created dynamically).

I dragged in 5 identical widgets. On first compile, all 5 threw an error. I then deleted them all and tried the exact same thing again. This time 2 threw an error and 3 were ok. I then deleted them all again, dragged them in one at a time, compiling as I added each button. And… magically they all worked. sigh.

Not sure what else to do. If I can’t consistently reproduce it in my own project I can’t imagine a clean project will reproduce it.

all of my copy/pastes produced the error, but dragging from the palette for each of the slots worked for me. 4.16.2

er i assumed you were on the same tutorial as me, sorry.

produces the error during the tutorial at 23:00 (4.8 i think) if that helps any, by copy/pasting user created widgets and I solved by dragging individually from palette instead.

Are you using 4.16 too? I didn’t have this issue with 4.14.

Not sure if this is the best approach but it worked for me.
Assuming tha you are following this tutorial,
go to InventorySlot Blueprint → Graph tab. In InventorySlot variable, uncheck Instance Editable. Compile and Save. Then, checki it again, compile and save.
It worked for me

Thank you for your solution!)

Thank you - This solution also worked for me. Was following the UE4 tutorial - “UMG UI Inventory: Menu Layout | 04 | v4.8 Tutorial Series | Unreal Engine”.

I had this error too because I copy-pasted user widgets. When I dragged them in 1 by 1 I was able to compile.

I had this error and was able to fix it by closing the editor, opening the asset and compiling again.

I was having the same issue with the same error message - I was trying to have an actor reference as a variable. The issue was because my variable was named the same as one of the UI elements in the designer window. On renaming the actor reference, I was able to compile the Widget Blueprint.

Same Here. Following the Tutorial using UE4.19 and received the same compile error. Unchecking Instance Editable in InventorySlot allowed the GameHUD to compile correctly now. Thanks!

I was having the same issue while working on a udemy course and found the answer for my issue. In the widget you’re working on go to graph, class settings, widget blueprint options and check mark force slow construction path. I did that for all my widgets and everything compiles fine now.

Oh wow. There really is a checkbox for everything! Thanks for the tip!

This worked for me.
As mentioned above unchecking the “Instance Editable” didn’t work for me because I couldn’t uncheck it. Clicking on the box only made the panel flash.

UE 4.19
OSX 10.13.5

And if you’re not following that tutorial, it will work to simply go to the child widget’s blueprint, uncheck all the eyes that you can (editable), recompile both the parent and child widgets, then turn back on all the eyes (editable bools) that were editable before, recompile, no more error! Thanks Mirrol!

Thank you so much, i really dont know why i can not like the it but this is correct!

i can not visit the website u gave.
it says: The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

but the solution on the bottom is correct too

Thank you! It fixes my problem too.