UMG Text Widget Impossible to Change

I have a EntryWidget that I want to use to display a row for a Quest Item.

I have tried… binding, construct, preconstruct and even events.

I have been able to get the text to confirm it’s in the Text Widget (during the event) but possibly not rendering correctly because it may need to happen at construct. So my question is, how do I tell my widget “There’s new text, please render it”.

I tried Request Redraw but I have nothing popup in context.

I tried also passing a pin of the actual text to use passing to preconstruct and/or construct, and no matter what I pass through that pin, the EntryWidget never receives the value.

It’s almost like EntryWidgets cannot receive anything, which is dumb because I don’t want to create a giant library of widgets custom designed with text I would be pulling from a DataTable.

Anyways - kind of giving up after 3 hours, tutorials aren’t helping, people are posting about a similar issue but this one is extremely simple and shouldn’t take me so long.

I’m using the Add Item for Listview, but I want to update the EntryWidget before it goes into the list (I would even like to be able to update that information afterwards if possible, since things can happen while the user is doing things in the UMG).

Any help is appreciated.

To confirm where I’m at, I can see that there is text set in the Content → Text section, but it does not render on the screen in the ListView. It will just render an empty item with my icon to the left of it.

If I did "Add to Viewport, obviously it adds it to the left of my screen, outside of my ListView (which is the wrong place for it). Why is this so difficult :confused: