UMG - Text blocks loosing text when i compile.

I’m having this strange problem in 4.7 that when I add text blocks to a widget and change the text it does not change on the viewport (unless you change the color/alpha of the text). Also in the hierarchy it changes all text blocks to display the text I’ve entered.

When compiling the Widget it reverts all text back to ‘Text block’ I’ve tried creating new widgets and keep having the same problem.

The link is dead, will this be fixed in the next update?


This is a known issue, and is caused by all text in UMG being given the same key for the LOCTEXT system. The offending change was removed by the following revision:


Dead as in 404? You have to be logged into GitHub with an account that has permission to see the UnrealEngine repo, otherwise you see a 404.

It will be fixed in the next update, yes. Are you using a 4.7 preview (rather than the GitHub source)?

Hey Jamie, I’m getting the same error in UMG only with Images instead of text - whatever I add into the image box will be cleared when I compile it.

Github will fix that? I’m just using the UE4 4.8 as its the most recent download, but… I’ve been seeing that there are benifits to using that (i’m just not sure if that’s something I really know how to do. Like, I use Ue4 blueprints, so unless its the same program i’d be downloading and using, it all seems kind of iffy to me. But… i want it to work so… yeah please advise :slight_smile:


We’re not currently aware of any issues where images would be lost when compiling your UMG blueprint. Does this also happen on a new project, or is it limited to your current project?

I wouldn’t advise using a GitHub build unless you’re comfortable compiling it yourself. It’s a simple enough process, but unless you’re going to benefit from it (and you likely won’t here as we don’t have a fix for your issue), then it’s probably not worth it.