UMG - Progress bar not updating correct value

I am trying to set up a basic Health bar using the progress bar in UMG. I have create the function for getting the updated value and made sure it is bound correctly to the progress bar. But when I run my game, the progress bar defaults at 0 and even when my character’s health is at 1 or taking damage, the bar doesn’t update. I did some breakpoint toggling and its clearly showing the return node is not updating with the correct value.

Any solutions?

drag of the current health and divide that by 1.0 and it should work did you bind this to the percent if it still doesnt work just make a max health set to same value as health and divide the 2


Make the function pure

I have tried the dividing by 1 and the MaxHealth I have set, no change. As well, I did confirm the binding is to the percent, Unless the progress bar in 4.20 is no longer based on percentage.

that may explain the “deleting a node and replacing it” magically has caused some of my other blueprints to work (and simultaneously not work)… Ill try it later.

Not stupid at all happens to me alot glad I’m not the only one that suffers from it

Haha, yea…I’ve spent hours trying to fix “problems” that weren’t “logical” issues at all only to find out after being completely frustrated and turning the system off for the day come back to find the nodes working as expected. Or I decide to start over and recreate the script going over it with a fine tune comb, trying to think out each “node” and what it is doing, I end up recreating the exact same set-up and it works. So now when basic things don’t seem to work like they should I just delete and make a new node.

any update to this

After some testing, it seems that nuking it and remaking it from scratch worked.

It may seem stupid but sometimes blueprint nodes just “break”, no explanation for it. Delete the binding and re-create it and see if it updates.