UMG: Only power of 2 image shows correctly in iOS


I’m working on interface these day, I find that the only images, size of power of 2, shows correctly in iOS.
An image, original size is 44x44, is displayed as white box in iOS but shows fine in android.

Is it bug? or should I have to fit the UI image to power of 2?

Howdy cordi1203,

Thank you for reporting this issue that you have been seeing. I was able to recreate the issue with ease. I have placed ticket UE-8923 into our Bug database so that the issue may be resolved in a future release.

Please let me know if you have any additional questions.

Thanks and have a great day!

Hi Pak-X,

I have just checked the ticket and at this time the issue is still marked as unresolved. I am unsure as to when this issue may be resolved and implemented into the engine but I will be sure to keep you updated if I see any progress being made on the issue.

Thanks and have a great day!


we also have the same problem but for us this is not the case for all textures that arent power of two. Only some of them dont show up for some reason.

Is this issue still not fixed?

I couldnt find the referred ticket anywhere. There is a huge list of tickets in the release notes of unreal 4.7, but this didnt appear in them.

I have the same issue even though all my images are power of two. I have png images 2048x2048, all devices work properly except iPhone 6 plus. I see a small white box instead. Anyway to fix before waiting a new release?

Howdy jedisongoku,

Thank you for reporting the issue that you are seeing. I have just attempted to replicate this issue internally and have not been able to replicate this error on on iPhone 6 plus. I tested with both a power of two image (2048x2048) and a non power of two image and they both show on the device. What version of UE4 would you be seeing this error on? Is that build a binary or source build of the engine?

Any additional information would be greatly appreciated.

Thanks and have a great day!

Hello, I’m using 4.6 github version because I have other issues with 4.7. I have 2 images one for 4:3 and one for 16:9 screens. I get the brush by checking the viewport size. I’m not sure if there might be another problem. I compare the Y value of the viewport to select appropriate background assuming iPhone 6 plus Y=1080.

If you convert the Y to 1242, would you see the same results?

I have just tested a simple UMG setup and have still been unable to replicate the issue. Would you be able to reproduce this on a blank template project?


Since I do not have iphone 6 plus, I did not know what the resolution is. I checked it on my friend’s phone and the value I got is 1472x828. I will try 1242 and 828 and let you know about the result. Thanks.

This may very well depend on the version of iOS and the specific device, because “white NPOT” is a potential symptom of the GL Implementation thinking the hardware isn’t happy with what you’re requesting.

1472x828 worked for iphone 6 plus. finally submitted my app for review :slight_smile:

Glad to hear that you were able to resolve the issue and were able to submit your project. If you run into a similar error in another project or in a later build, please feel free to reopen this issue.

Thanks and have a great day!

I have also experienced odd behavior with non power of two images. I fixed this by finding the specific images and changing their default compression from DX## to RGB and they showed up OK.

Howdy jeffvoigt,

Thanks for the additional information and power of 2 images and how these can be fixed. I have just checked on the status of this issue and the Bug has been closed and is showing a fixed version of 4.9. I am currently unsure as to when 4.9 will be released but I will be sure to keep you posted as I know more.


Any news on this ? The problem still happens in 4.83 and 4.9 preview.

UE-8923 has been completed and fixed for 4.9. If you have any further questions, please let us know. Have a great day!

The problem still happens in 4.9

Hey Daihao81,

I have tested this out in 4.9.1-2689999 having the power of 2 set to none in the images will still show up in the viewport once set up in UMG. This issue is not recurring anymore.

If you notice that you are still having trouble, please upload the full reproduction steps in order for us to test this further, or upload a project it’s happening in.


Any update on this? I was able to reproduce this with 4.12.5 on an iPhone 6

This was resolved in 4.9. If you suspect there is an issue, please submit a new AnswerHub as a bug report.

Thank you!