Download

UMG - Issues with casting text variable

Hello,

So everything I cast to my UMG Widget works perfectly fine, except for a simple text variable. Simply doesn’t work.

So it will display the “default value”, but won’t display anything I “set”, it’ll just stay blank. So my obvious guess would be that it goes wrong while setting that value. If instead of casting to my widget I just use a print string node, it’ll work fine. That’s the strange part.

This is the UMG information:

24372f4dc268adcf21be1283b30d818f242f8f0a.jpeg
number2.png

This is the information from the character from which it is cast. To be clear, it casts everything else just fine

number3.jpgnumber3.jpg

Does your character pawn still exist in the map while the widget is trying to get the text?

Yes, but the game is set to pause

Disable the Pause function and test again. if it works then, add a delay before the pause node so the Widget has time to update. If it still doesn´t work then…you know that it´s not the PauseGame node that causes the issue :wink:

When I read your comment I was like “yeah right”, then I tried it… actually solved it. Feel so dumb hahaha

EDIT: So I put the set pause after casting the widget, with a short delay, and it works perfectly fine now