UMG is crashing on Android device Sony XPERIA S

Project without UMG is working fine on XPERIA S device. After even empty UMG Widget is added to the project application is crashing.

Hi ArCorvus,

  1. What is the OS of the Xperia?
  2. Do you get the same crash on any other devices? Particularly devices with more recent GPUs than the Xperia, if you have one.
  3. Can you provide logcat logs for the Xperia crash?
  1. OS: Android 4.1.2 Jelly Bean
  2. No, crash (deadlock) is happening only on this (XPERIA S) device.
  3. logcat. I don’t know if it will help. Is it any chance to make crash dump or get call stack on Android device?

Last string from logcat regarding my project (1905):

07-02 01:10:47.773: A/libc(1905): @@@ ABORTING: INVALID HEAP ADDRESS IN dlfree addr=0x5cc4e380

Project crashes immediately after “Add to Viewport” node is called.


Hi ArCorvus,

It looks kinda like you’re running out of memory on this device. Can you shut down all unnecessary applications and try running your project on the Xperia one more time? If it crashes again, please attach the second logs.


Hi ArCorvus,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.


I have investigated this problem again. First of all, latest project Unreal Match 3 v.4.11 works on Xperia S. That was very strange and I started to dig in that direction.

What I understand after a few days of investigation is that Match 3 is not crashing because it has very special widget that is loaded first (/UI/TitleScreen). This widget has enough text characters to work. If I remove (or hide) any single text field from this widget it stops working.

So I have updated my sample project (in attachment) to UE4.11. I tried to run it on Xperia S but it has crashed. Then I added the text field to the widget and it helped. I founded out that text should be at least 51 characters long (or 26 if text has shadow). If widget has other visible elements text could be shorter.

So as far as I understand there is a crash on Xperia S when widget that is loaded first contains “not enough” visible elements.

I guess that s3 mini experience the same problem.

I have attached both projects (with crash, works ok) and their logcats (with crash, works ok).


Hello ArCorvus,

I was not able to reproduce this issue on our end using the project provided above. Could you try and make sure that the crash still occurs in the zipped down versions of the project?

Hi Rudy,

I can confirm that crash still occurs on XPERIA S. To be more specific the application is not crashes but stops responding.

I’m ready to give you any assistance to solve this issue.

Hi, Xperia S user here too and am having the same problem. A simple project with UMG gives the not responding error. But the same project works on Galaxy Tab 2, which is much less powerful.

Hello ArCorvus,

We have ran a few more tests but I have not been able to reproduce this error on our end with the project provided. A couple of questions for you. Are you launching on or packaging the project completely out? Do you have any other applications running in the background on the device? Do you have any other devices that are experiencing this same issue?

Hi Rudy,

It seems that XperiaS is only device that is experiencing this issue.(
I checked out both launching and packaging shipping configuration, the same as development configuration. I have ran application immediately after device reboot, there are only system applications on the background. Also I tried to kill all application before run. Crash appears in all this cases in testumg_crash. But the version with numbers works fine in all this cases.


I found the problem, I installed a custom version of Android Lollipop on my Xperia S and everything works fine. So its not a problem with the phone its a problem with Android OS. Its not working on other 4.1 phones for me as well.

Hello Avagantamo,

Could you provide a list of other devices that you have been able to reproduce this issue on?