Download

UMG Inventory in UE4 (Videos)

I’m having trouble setting this up. I have set up the system the same as the videos but I cant get my inventory to came up, when I press “I” nothing happens the mouse comes up but no invertor menu, when I press “I” again the mouse goes away. I have rewatched the vids about 3 times but I cant seems to find what I did wrong
any tips on what I did wrong?

I didn’t watched the vids yet so sorry i can’t be of more help, but maybe you could take a look at the project itself made by Wes Bunn which is downloadable in the Launcher (in the Learn Tab). Maybe there you can find the difference with yours.

Regards.

Double Check your Inventory Animation, this could be your problem

Well, since there’s no official topic yet, I’ll help you out by bumping this with a question of my own:

I did everything exactly as the video said, everything is working, 'cept for the Pickup Item Text, for some reason I can’t understand -I even modified every single field on the widget blueprint- I can’t get it to get centered on my object.

75a7f463e87d63c3042ab15b4ca26cd933925b56.jpeg

Also, once I go away, the text keeps appearing in front of me:

Anyone have some input of what could it be?

Hello Mrdazza,

So nothing happens when you press I at all? Any chance you can post some images of your Widget Blueprint setup? You could also try placing a breakpoint on the I button press and step through the Blueprint to see where the issue is occurring. Someone else had mentioned it as well, you can also download the project from the Learn tab under the Gameplay Concept Examples section and cross-reference.

-W

Hello Fdslk,

Regarding this issue, does the issue occur when playing inside the editor or only on a new window (standalone game preview). This might be related to the question here:

I’m currently checking with the programmer for more clarification on his setup.

-W

I’m having that issue in both in-editor and new windows preview

thanks
the mouse come up when pressing it and disappears when pressing it again. I can pick up “said” object and text come up, I have looked over the Widget blueprints and compared it to the ones in the Video, and it all looks the same, I’m also using this as a to help with fault finding in Blueprints, im going to try it again in anther project as well when I get some time. I like the tutorial Videos a lot and I learn a lot, but I would like some more explain some steps e.g. a more detail or a reference on where I can find more detail. like the inventory slot widget and the button I crated, what was is that for? why did I need it, I did what the video told me to do, but why? also there where some variables the where crated but I never see a reference to them again.

Not quite sure what may be causing this but I do have an email out to the programmer regarding this, will post once I get an update.

Thanks for the feedback, I will make sure to provide more steps and clarification in the videos in the next series I do. Regarding this series, if you post some images of your setup I may be able to help diagnose the problem.

Have you checked inside the MyCharacter Blueprint for the I Button press section, that you are setting the widget to Visible the first time it is pressed and Hidden the second time it is pressed (yellow boxes below).

If you set up like above and have made it all the way through to the section of animating the Inventory screen so that it flies in and out, there might be something setup with your Keyframes. Have you tried bringing up the Inventory without animating it? In the image above, connect the Green Arrow from B and plug it into the Set Menu Open node. Also, disconnect the Play Animation node at the end of the A side of the FlipFlop node (disconnecting the node that is marked with the red X).

These are some things to try, not quite sure without looking at your setup.

Relax dude, just this weekend found out how to solve it, I was using adaptive Vsync with my video card, turning it off solved it to me.

Good deal, reason I asked is I think I have seen the issue as well when running different screen resolutions where everything appeared to be working fine on one setting but not another. :slight_smile:

thanks, was bunn your the best!

I had Action Menu a target (the blue output) , not inventory Manu like the picture above.
I really don’t know how I missed that when I was looking though it 7 times. I think I will re-watch the vids again.