UMG Inventory (following tutorial) - No pickup text hovering over in-game actor.

I’ve been working on an inventory system for my game for the past few days. I’ve also been following Epic Games’ tutorial on creating an inventory system using UMG, [found here][1]. Having made it to the start of video seven, I thought I’d test the functionality of my code and it turns out that I’m running into one problem that I’d like to correct before moving on to anything else. I believe that I’ve been following the series to the T, but I must be missing something…

My issue is that, when approaching an item that can be picked up in game, text should appear above the in-game actor like in the tutorial, but does not. Briefly, the pickup text will flash in the top left hand corner of the screen, where the text block was created in the widget. After that, it disappears, never to be seen again.

I have an error log that gets generated after a play session that reads “Accessed None ‘pickupActor’ from node Set Position in Viewport in blueprint PickupText”, as seen below:

The last image above is showing that I’m setting my pickupActor variable in my actual item blueprint. I think this is were the problem lies, either at this step, or how the pickupText blueprint is receiving the information from the item blueprint.

I tried plugging in a simple “print string” node to test and make sure things were working in other parts of the script, and they are. Attaching the print string node after the event tick yields this result; the string being displayed on screen at every tick and the pickup text being displayed in the top left hand corner of the screen.

Any assistance in resolving this issue will be greatly appreciated. Many thanks in advance!

Ryan did you ever get an inventory system made? I’ve been at this for 6 days now and doing all the tutorials and they are either broken or outdated and rely on options not available anymore. I’ve looked everywhere I can think of!

Unfortunately, no. I’ve done the same thing and tried using different tutorials, but only to draw the same conclusion as you. I wish I could say that I have a working one. I’ve given up on the inventory system for now, and I’m busy with working on other mechanics for my game.

Dude after 6 days I posted in a facebook group right after I wrote this message to you and it was made apparent to me that now if you go into the learn section of the launcher, scroll down to Gameplay Concept Examples there is actually the Inventory UI with UMG project right there for download. I’m taking it apart right now and seeing how it was made but it 100% works. I guess I’ve learned a lot about blueprints over the last week so it wasn’t a waste of time but I cant believe the launcher learn section was the last place I looked. It def isn’t indexed by google that for sure!

I hope this helps you like it will me.

Here’s the link to the group that helped me if youre not in it already.

This tutorial have alot of errors…

Your error mean PickupActor variable is not set in PickupText class, which must be set by CanPickup class.
Check this:


Also reroute is buggy. If everything set properly try delete reroute and connect directly to “Set Pickup Actor” and “Set PickupText” targets, though it should throw error at the compiling.

Thank you very much for explaining that. I’d like to test if that would solve the problem, but I’ve already began reworking my inventory system based off of the content example that joplin pointed me to. Your solution makes sense and I appreciate the time you took to find it very much.