UMG Interaction with Particle System

I have a problem with UMG interacting with particles system on my actor.
I have a key bind on my Player Controller that activates the particle system of the actor which works perfectly fine,

Inside the UMG I have a button that when pressed calls the function inside the Player Controller, and should activate the particles.

However, when I press the buttons made using the UMG I get all Add force results, the exact results but without
the particles been activated.

I try running a print string to see if I was getting the function to be called, and goes through to the end without a problem, but no particles are turned on whatsoever.

I am not sure what I am doing wrong can anyone please help?

I’ve thought I had similar issues in the past just to discover that the particle system was misplaced or it was very small. Have you tried drag/dropping your particle system directly into the scene just to ensure that it is visible? (Also, I’m sure you have already done so, but just in case be sure to check that the location input on the spawn particle system node is correctly connected.)

Thanks for your idea James.

After taking another look I decided re-wiring my whole system and guess what?

It worked fine! I got the buttons from UMG to active the particles from my actor without a problem.

Cheers all sorted. :slight_smile: