UMG images importing without blue channel

The images we are importing are coming through missing their blue channel data. Images are in .png format and have been tested with different image editor programs and different systems and versions of UE4.

As can be seen in the picture the preview of the image is purple (the correct colour).
Turning the green and red channels down and the blue to max results in a black image, illustrating that there is no blue data.

Attached is one of the exact image we are using, but even some different shades of purple and blue have the same result.

These issues are only happening in images with a majority of transparency. We have some images with transparent corners or decals of the same purple and blue shades that are not causing issues.

Can you double click the image in the Content Browser and ensure the compression setting is set to Default. Perhaps it got imported as a Normal?

And since you’re at it, have a look at the Adjustments tab. Is there anything abnormal?

Thank you, this was the solution. Also had to tick sRGB and set Texture Group to World, for anyone else interested.
Appreciate the help :slight_smile:

Please consider accepting it as the answer if the issue is solved. Thanks!

set that to default after double clicking the image

Here the compression setting for anyone who couldnt find yet.
It is in the ‘details’ window.