Download

UMG Image Widget Error

I’ve been trying to get Image widgets to work for the past two days now, and I’ve had absolutely no luck.

The textures/materials I apply either don’t show or if they do it’s in a purple and yellow checkboard fashion.

Having tried multiple sizes and multiple file types for textures (.tga, .png, etc.), I’m out of ideas.

Oddly enough, if I select the UE4 startcontent, Crosshair texture it shows up fine…

For reference:

https://lh3.googleusercontent.com/-Wmhx_5UXuYI/V6DNNOmlbnI/AAAAAAAAASE/76Ip-P6qSp85QH72QmftYMysrDlxwvQuACCo/s1600/Image%2BWidget%2BError01.png

https://lh3.googleusercontent.com/-FAFIDgDWgyU/V6DNNM7duuI/AAAAAAAAASE/F3ZN5DMDzWMvvcB4Ot0cJo08KEe2TNZjACCo/s1600/Image%2BWidget%2BError02.png

https://lh3.googleusercontent.com/-zlKZfqNWLts/V6DOs2QmR0I/AAAAAAAAASQ/4ID8YPFn5awOSeLjUvzIXbjlOcQRerhKQCCo/s1600/Image%2BWidget%2BError03.png

Any help is appreciated,

~ Jason

That pattern means you’ve provided a resource to Slate that we have no idea how to render. Your brush says you specified a Package - that’s not a valid asset type for brushes. You should only have been able to pick Textures or Materials I’m a little confused as to how you’ve managed to select that.

For some reason whenever I select a custom texture or material it comes up as a “Package” instead.

~ Jason

How are you creating the textures? Is this a customized version of the engine?

Simply by importing an image file. I don’t do anything beyond importing.

Nope, not custom.

As a sidenote: It’s on version 4.12.5.

~ Jason

Curious, can you zip up one of the uassets and source textures and send it to me?

Here you go:

~ Jason

Btw, does your texture open correctly in the content browser and launch the texture tool no problem?

Yep.

I’ve even made a material with the texture and have successful place into onto both Geometry and Static Meshes.

~ Jason

Hmm, tried it with 12.5, both the import and the existing uasset work fine. How are you selecting it? Just through the drop down? It’s strange that it’s showing the full path, and not just the name of the asset.

I’ve tried both dragging and dropping as well as using the drop down menu.

Well…at least it’s not the files.

~ Jason

Was this ever solved? I’m on a non-modified version of UE4 (4.9) and this is happening to me. It’s random as far as I can tell, as some of my imports have worked but others do not. Even though they were from the same export batch…

Would really appreciate any help.

Not really. I updated the engine, created a new project and everything was fine. I haven’t had an issue like this since creating this post back in 2016.
It was random for me too; some textures just would not work.

Can you update to a higher version or is your current project tied to 4.9?