UMG Image in Widget Blueprint is Faded but my Opacity and Alpha are 1.0

I’m adding a crosshairs to my HUD, but the image is getting an unwanted fade, as if the opacity is turned down somehow. When I create the widget and add it to the Viewport, it’s faded. When I draw the texture to the screen using Draw Texture, it’s not. The attached image shows drawing a Widget which contains the texture, next to the texture drawn using the Draw Texture node, both using the same texture asset.

The texture looks faded in my Widget Blueprint as well. Is there a setting somewhere that causes the opacity to go down? In the Widget Blueprint, the image has Color and Opacity settings with all R G B and A values equal to 1.0. The Canvas Panel also has Render Opacity of 1.0

Something else I noticed is that in GIMP, my image is crisp as in the below image. However once imported into UE4, it looks blurry as in the widget Blueprint. Is there some sort of auto-blur happening? And why does the texture look crisp when drawing it to the screen using a Draw Texture node?

I have discovered that in the Widget Blueprint, with the image selected, I can un-check Inherit next to the Tint property in the Appearance section and it gets a little less transparent, but it still seems a little faded compared to drawing it with Draw Texture:

Double click that image in the content browser and:

Annotation 2020-07-09 071523.jpg

Thanks Everynone. I also noticed that when I play in PIE in a standalone window (Standalone Game) or press Play from within a Blueprint, the texture is clean and bright, but when I play from the Viewport, it’s faded. Any idea why that is?
I appreciate your response.

If peoples comes here with the same problem in their Widget Blueprints, you need to check the “Behavior” “Is enabled” checkbox :wink: