Download

UMG Image does not keep alpha channels when I go ingame

So I am making a UI border and I exported it as a PNG from photoshop and it has the correct alpha when I open it on my desktop and when I open it in the content browser in unreal. When I spawn it in though with my hud it loses its opacity. I have no idea what is wrong and it would be helpful if someone could give me a fix.

just for test using https://www.w3.org/Graphics/PNG/alphatest.png importing with the default setting of the new 4.13 with a simple create user widget + add to viewport in BP everything is fine for me.

the difference is in the format of the png image texture in the UE editor:
your is a “DXT5”
mine is a “R8G8B8A8”

which png format do you use?

What do you mean? I exported it from photoshop

Actually I just found this and I can change then compression types and one of them is almost what you have but the R and B are switched around but it doesnt fix anything.

sorry wrong order with the R and B. I did the test in the other way using a DXT5 png, and for me it works too. png compression format seems clear. Must be something else.

how do you add your widget to the viewport? (cause the problem appears only when it’s in the viewport, not in texture editor or UMG editor)

I am adding it in my character. I was going to do it in the controller but it wasn’t getting called so I moved it.

@Almedi adding it in the BP_player or in the level BP doesn’t change anything ( for the png transparency problem you have, as long as you don’t apply some effect/modificator to it)

any post process effect applied ? (trying to find where you could alter your png transparency)
or any idea if somewhere in your code you are doing something that can sharpen/remove the transparency ?

I found that it was also being added in my hud so I’ve removed the references in the player and it is only being added in my hud now. I tried the test image you used and the same thing happens. Also I tried on a separate default thirdperson bp and it worked so the problem might be with the project settings.

When I’ve seen this problem reported in the past, it’s been because the user was adding the UI hundreds of times to the game, usually every tick creating and adding a brand new widget to the viewport.

I didnt even notice that but it was every tick. Thanks so much.