UMG Image color/tint loses changes after compiling

Hi all,

For some reason when I change the Color or Tint properties of an Image or Border in UMG and hit Compile, the colors revert back to white. I’m not sure if that’s a bug or I’m missing something?

I made a video about it here if you want to see it in action: Unreal Image Bug? - YouTube

Saving before Compile doesn’t make a difference. I’ve tried it in a different project, in new Widget Blueprints etc it still happens. Haven’t tried a different editor version

Thanks for any help in advance!

[EDIT] So… if I change the color (e.g. blue), Save, then exit the editor and reopen it, it keeps the new value I changed to (blue). But if I change again (e.g. red) and hit compile it reverts back to the value I had when I opened the editor (blue)… That’s very annoying.

  • what are the chances Event On Initialised or Event Construct overrides it?
  • is there a forgotten binding somewhere?
  • perhaps we’re dealing with reparented widgets and parent’s calls mess it up?

Hi, no custom events are implemented/overridden. No bindings created. The border is a direct child of the default Canvas Panel that Unreal creates.

Can you reproduce it in a clean project? Can you repro this in an older version - 4.25 (if you have it sitting around)?

Had a look at the bug DB but nothing pops-up. If this is an engine bug, that’d be the 2nd one I’ve run into today that’s related to 4.26 and widgets.

Yep will do both when I get home from work in 5 hours-ish. When googling I’ve seen a few forums posts similar to this (widgets losing values on compile) with no replies…

Hey, so tested on both 4.26.1 and 4.25.4, brand new blank projects, similar issue!

Steps I did: Right click > User Interface > Widget, call it TestWidget, double click it, add a Border to the Canvas Panel, center/resize it, change Brush Color, save, compile, changes lost.

So it seems that if you change the color of something, you MUST click the “OK” button. If you click away to hide the color picker (which is what I’m used to from pretty much any software with a color picker…), the color will change but wont save, so if you hit compile the values are reverted.

I just want to follow up that I encountered this behaviour in UE5 and it seems to be specifically when using the color picker. What I realized was happening was I was color picking from a different UI Image, which was not just picking but also selecting the other UI Image. The Image I was trying to change the color of appeared to have changed, and the color selection window stayed open (I even Clicked the Ok as described above). The Image I was trying to change appeared to be updated when I navigated back to it but when compiling it reverted back to the original (incorrect) color.

So basically I have two UI elements UIA and UIB. I have UIB selected, color pick from UIA. UIA is now selected, UIB appears to have its color updated, however when I compile, the UIB color reverts to what it was before. The tooltip with the Ok button is still open, but even when I press Ok it doesn’t save the changes properly. Weird and obscure issue but hopefully this helps someone else.

I’ll also just add that I was able to get this to work by color picking, copying the Linear Hex code for the color, reopening the color selection window and pasting the value in manually.

I’m experiencing this same issue and do not see an “Ok” button anywhere. Specifically I’m copying and pasting the entire Appearance settings from another widget to a new one and am experiencing this.