UMG Grid Panel Hovered State Doesn't Clear When Hidden

If a UMG widget is closed with the mouse over a Grid Panel the state doesn’t get reset it stays on true until that same Grid Panel is hovered again.

This is also occurring for me. I use the widget Hovered state for a lot of things in my interface and before version 4.12 everything worked fine.

Now it seems when hiding the UMG Widget it doesn’t clear the hovered state properly most times causing it to report IsHovered as TRUE when the UMG Widget is hidden and no longer hovered by the mouse cursor.

Hello ,

I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any widgets/blueprints that may be involved?

Hi Rudy,

I will try to reproduce this issue and provide details and a test project for you, thanks for the reply.

Hi again Rudy,

I’m still trying to reproduce the issue my project has, but i did come across another way to produce it which mite be related?

If you hold down a mouse button when hovering the grid panel then hide it this will also give the same result, You can then move the mouse around in game then set its visibility back to visible and the state will still return true even know the mouse is no longer over the grid panel.

Here is the project ‘I’ to open the dummy inventory.

Test Project

I will continue to try to get this issue to show.


Hello ,

I was able to reproduce this issue using the project provided. I have written up a report (UE-32910) and I have submitted to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

Thanks Rudy.

Hi Rudy,

I did end up reproducing the bug in the original way i mentioned, and i would like this added to the bug report incase its related, It seems the mouse doesn’t need to be held down to reproduce it using this method.

The Set Input Mode node seems to be related to this bug, a test project is below.

How to reproduce this issue using this test project.

  1. Push I to open UMG
  2. Hover the widget a drop down will appear
  3. Close UMG using I when still hovering the widget
  4. Move the mouse to a new location
  5. Reopen UMG
  6. The hover drop down will still be visible

It seems that the Set Input Node stops the engine from clearing the state.



Hello ,

Thank you for the additional information, a link to this thread is already included in the report. If more information is need they will be able to check the link for more information.

Guys? I assume 4.17 still hovered?

How about “Set Style” Node for Button or Checkbox? In theory it must set/reset Style upon close or open (wherever it is used) of the Widget. Just make it unhovered using “Make…Style” Node:)

Hello Two-faced,

I have provided a link to the public tracker please feel free to use the link provided for future updates.

Link: Unreal Engine Issues and Bug Tracker (UE-32910)

Make it a great day

@Rudy Q I’m running into this all the time, I could really use a fix. Should I provide another reproduction example?