UMG Events don't execute in packaged game

I have a lot of code similar to this in the event graph of various UMG event graphs:


It all works fine when I run it in PIE, but no event ever gets executed when I “launch” or package it. It doesn’t matter if I use EventTick, EventConstruct or some custom event - never gets executed.

I don’t know what else to tell you… I always compile selecting Development.

Do you have an idea on why it doesn’t get executed?

EDIT: Wrong answer below:

Huh, I got it. Turns out all you have to do is deleting your Binaries, Build, Intermediate and Saved folders, reopen the editor and repackage the game.

… I hate blueprint bugs.

EDIT: See problem in comments

Ups, turned out I was wrong!

Actually, it works when you delete those folders and launch the game.

If you package the game, it doesn’t - regardless of wether you deleted the folders before or not. And after building the game once, launching doesn’t work either.

Seems like this issue does not appear in new simple projects.

I just uploaded my whole game so if someone from epic wants to have a look at it, just tell me for which E-Mails to unblock the download.

Also I just noticed: KeyDown functions don’t work for me, when the game is packaged. I set them up like this and they work, but they don’t when the game is packaged.

I wonder if that is related.

I just checked. Not working in 4.7.6.

It’s been 20 days and I don’t know what to do. I even uploaded the game!

Is there anything I could test, try or do?

Any suggestion at all?! Please!

Hello Deventico,

I have a few quick questions for you that will help narrow down what issue it is that you are experiencing.

Quick Questions:

  1. What platform are you packaging for?
  2. Is the project that you are having issues with been upgraded from older versions of the engine?
  3. I see that you mentioned providing your project, could you point me to where I can find it to take a closer look?

Thank you!!

  1. I’m packaging for windows
  2. Yes, the project started around… 4.4 I guess? About october last year.
  3. Yep, the project is still uploaded here.

I deleted all unnecessary stuff, you should be able to build the Binaries yourself, if necessary.

Please tell me when you finished the download, so I can make the access private.

Thanks again!

Hello Deventico,

After looking through your project I have found that you appear to have circular dependencies in your Character blueprint. This could be what is causing the errors that you are seeing. The dependencies that I have found appear to be those between your Character and your soldiers. After reading your post about how things work one time through after deleting your saved files, this theory becomes even more likely. I hope that this information helps.

Make it a great day


I deleted all circular dependencies between the character and the soldiers (MyCharacter has references now to the soldiers, but not the other way round) and checked for correctness using the reference viewer.

But that wasn’t it. Blueprint events still work in editor and still fail when packaged.

After reading your post about how things work one time through after deleting your saved files

In my comment I stated explicitly, that this theory is wrong.
This approach only works when I launch the game. When I package, it never works.

I have searched for more circular dependencies and actually found some, that solved some problems in some widgets. Not all - but I’ll keep searching for circular dependencies.

Could you explain what’s the state of circular dependencies right now?
Should they work and are being fixed? Or is it recommended not to use them? Both?

Hello Deventico,

I revisited your project and I was able to to the UMG to function.I did this by snagging the current widgets that are being displayed on screen and placing them as children into a new master widget. I hope that this workaround may prove useful for your project.