UMG elements are shaking when being rotated.

I’ve experienced it once, too long ago to recall what the workaround / solution was.

You could experiment with adjusting the size of the image to the power of 2 and/or tweaking the pivot the whole thing rotates around (although it seems you’ve tried that already).

Also try rotating the entire widget vs rotating the image within a canvas and see if it makes any difference whatsoever.

Hi.

For few days now I have been bothering with a problem where rotating widget elements are ‘shaking’ a little, which is unfortunately very visible and annoying. I suspect it is due to how pixels on screen are being filled during the rotation, but by looking at other games if it occures, it’s not really visible and definitely it’s not distracting the player from actual gameplay. I have tried different settings for imported image(It is currently set to UserInterface2D with lowest compression). It didn’t matter if image was rotated using SetRenderAngle function or through material. I’ve also tried rotating simple circle with it’s pivot set to center, but the result was the same. You can see the problem on video below.

It’s more visible when other elements of the UI are present, but unfortunately I’m not able to show you that.
My current ‘solution’ for this problem is to have circles separated from the arrow, and only arrow rotates. The shaking effect is now only visible on the arrow and looks a lot better, but the problem is not really solved and I want to limit myself on the number of images being rendered on the ui, so I treat it as a temporary solution only. Is there any possible fix for this problem?

rotating entire widget doesn’t work either

Is anything containing the rotating widget set to Size by content (or whatever it is called)

yes and no, I’ve tried both options

I have the same problem with UI elements shaking. Does anybody know how to resolve it?

It’s not a solution and more of workaround imo, but I’ve made every circle as a separate static image, so only the actual arrow is rotating, the problem still exists but it’s barely visible and is in my tolerance threshold(unless I find a better solution)

I wonder if it is stretching and squishing to fit inside its container.

Change the UMG image to use a material instead of a texture. Then use a Rotator in the material. That will get rid of the jitter.