UMG Drag Drop Not Working - 4.20 (Packaged / Standalone)

We’ve encountered which seems to be a bug after upgrading our project to UE 4.20.1. Drag and drop operations just become broken on packaged builds or launching stand-alone, despite working inside the Editor (PIE).

I’ve created a new project to isolate the problem, this is how it is configured:

Slot component (which will be dragged):

UMG UI (no behavior, just using the slot-component ui showed previously):

Level Blueprint (used to add the widget to screen)

The problem: Each slot ca only be dragged once, after this “OnDragDetect” event will not trigger anymore, (this only occur when running Packaged builds or launching stand-alone version through the editor).

Is this an confirmed bug ? Any help would be appreciated. Thanks!


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


Exactly same problem. Have any decision?

I’ve reported the issue: UE-63076 (it can be found here), but it has been marked as “Non-Issue”, what does that mean ? Does repro steps where unsuccessful ? Thanks.

Be wait together.

I’ve created a repro project with this issue isolated. Playing “Stand Alone Game” behavior differs from editor and becomes broken after the first drag and drop. You can download it here.

This problem was occurring since i was passing the same widget (self) as payload parameter during drag operation creation, which seems to trigger some recursive conflict on UMG input handling system. Passing only the image (or any other component) as payload parameter will fix this issue.

I still think this is a bug, since PIE / Stand Alone and Packaged version behaves differently, also, this was not happening on UE 4.19.

same problem here

It is still somewhat a problem. In packaged build, if you click and drag mouse quick, it will not perform a drag operation. It works if you do it slow (who does it slow?). But in PIE it works 100% regardless how fast I tried to click and drag.

Edit: It’s not the payload that is the issue, its the Default Drag Visual, you will have to create a throw away widget in place of using self.

My default drag visual is the same as the widget being dragged, (No way! Like, who in their right mind does this right??!) which caused me this issue, after reading this post, removed the payload, and still had the same issue in standalone. After restoring payload to self, and removing the Default Drag Visual, all works again.

1 Like

Had the same issue with 4.22. I fixed it by using the Image variable instead of self. Also had to resize the image in my case. An additional widget was not necessary.

Still think the editor PIE should not behave different than the stand alone version in this case.

1 Like

4.22. the problem still persists. =(

problem is still there on 4.26

Just to check, did you commit this as an official bug report? Since it is persisting for over 4 years now.

For people that have a more advanced system and would like to have their own widget as the visual representation, create a new widget of the same class and recreate it’s variables. Use that as an input to your default drag visual.

1 Like