UMG disables input? (modal is disabled)

I’m trying to use UMG as a HUD for my project, however it disables my input. Strangely enough when playing it in the editor (and not in a separate window) It will actually receive input until I press shift+F1 and then click in the game area to try controlling the player again. I’d really appreciate finding out why this is occurring, is there a specific UMG method I’m suppose to use for something intended as a HUD, I’ve tried various random settings but nothing seems to get the result I want. I’d greatly appreciate this being resolved as soon as possible, I don’t want to end up spending time on this and then finding out it can’t function as a HUD.

Thanks a lot for your response :), that’s awesome to hear for the future, but does this mean we need to wait until 4.5 to be able to use UMG for HUD interfaces? Was hoping to use UE4 for the coming ludum dare but I don’t have nearly enough time, especially without any visible tutorial, to attempt getting the master and working out what bugs it has separate to the release build I’ll have to work around which could be worse than just no available HUD framework.

Fixed in master :slight_smile:


Yeah - you’ll have to wait for 4.5. I’d give you the changelist that fixed it, but honestly I’m not sure, I’ve been revamping a lot of the input and focus stuff for UMG.

No worries, I look forward to 4.5, thanks a lot for working so hard towards such an awesome interface solution, goodluck revamping everything :)!

So I decided I really needed UMG for HUD purposes and spent today trying to get the master built from github…and it still doesn’t work. Is there meant to be some additional option I’m missing beyond modal in the actual blueprint widget?

Nope, can you send me something I can reproduce the issue with? I tried reproducing it on the FPS template and couldn’t.

When I was testing it with the FPS template, I was using an xbox one controller. Can you try just making a widget on master with just a canvas and see if you can get controller input in the game?

I discovered the reason you most likely don’t realize it’s an issue. Turns out that input works fine, but only for keyboard and mouse controls. Using the Xbox 360 controller plugged into the pc doesn’t work with UMG (tested on 3rd person blueprint template), however the keyboard and mouse work. Which confuses me because they are all set in axis mapping so it’s not even like buttons are working but axis’s aren’t.
My project I’m working on only uses the 360 controller (because the control scheme can’t translate to a keyboard), that’s why I didn’t know it was working at all until I tested it in a new template. Do you have any idea why the controller specifically wouldn’t work with it?

Nope still not working. May I ask when you were testing, did you just run it in the viewport? Because it does work in the viewport-until you press for example shift+F1 and then click on the viewport again to take control-intput is then lost from the controller. When playing the game in the “New Editor Window” you never get input with the controller even at the start, only the keyboard.

Literally all I have done is create the first person blueprint template, create a UMG widget, and add it to the level blueprint like this (have tried without/with that get player controller node)- . Should I be adding it onto the character blueprint instead? I can’t see what I could be doing that makes it not work for me.

Yeah ran in the viewport, and I attempted taking mouse back a few times with shift+f1 and always got controller support back.

This is not fixed in 4.4.3 as I’ve just annoyingly found out after spending the last 3 hours downloading the new version.

Its quite simple, if you call a create a widget and add it in the begin play event of the controller, controller input does not work in anything other than ‘play in selected viewport’. Keyboard and mouse input work fine though.

There is a workaround which I saw on another thread that worked for me. Add a delay of a few miliseconds to the widget being created in the begin event and it works fine then.