Download

UMG ComboBox isn't displaying the selected option (SOLVED)

Hello,

like the title says i have a problem with my comboBox in my widget. When i’m creating a new widget and place a combobox inside, everything is working correctly.
But in my Main Menu Widget for my game i’ve created, the selected option isn’t showing up. I can see the list when i’m opening the comboBox and i can see the selected option but not when it’s closed and inside the editor it’s not showing too. How can i fix this? Increasing the size isn’t working too.

EDIT: When i drag my Canvas Panel with my GraphicSettings outside the "BoxForOptions (which is a Horizontal Box) it seems to work. But the problem here is that i’m using the widget switcher and the fact that their can only be one widget be active by the time, this isn’t really an option for me…

So i’m still wondering what’s causing the issue here. Is there a limit on how many boxes or panels can be a child of some other box or panel, when you’re doing some kind of a Matryoshka-Style here?

EDIT 2: So it seems like i’ve solved it and found a solution. In the Render Transform of my HorizontalBox (BoxForOptions), i’ve set up a Translation for X to move my box to the left. Setting it back to zero and my comboboxes where showing the selected options again!

But it would still be great if someone could give me an explantation, why changing the translation would cause something like this…Thanks! :slight_smile: