UMG buttons not working when loaded from other level

Im trying to create a multiplayer lobby using umg buttons. The buttons work to move from one level to the next but when the level is loaded through the “open level” blueprint command the umg buttons onclick doesn’t fire. i.e. If im in the editor on the main level and the main menu is loaded all the buttons work 100% but when i click on the host button the lobby level is loaded and the lobby widget is loaded but the buttons doesn’t work, and the same case with the reverse when i start on the lobby level all the lobby buttons work 100% but when i load the main level the main menu widget is loaded but the buttons doesn’t work.
I probably just did some thing wrong. Any help will be appreciated.

When i run the editor as stade alone it works fine, but then i can only launch one process at a time and i cant test the network

I am also having this issue an so far haven’t found a solid lead on it. Using 4.14 currently, did you find a solution?

When the level load you may have to set the UI mode to UI and game again with focus on the widget.

I have not worked on UE in weeks, I will try and move to Bug report so it can be investigated. But as you can see I made this post in 2015… so It might have been fixed.

I will try as soon as I can and get back to you, but I cant promises that I will be able to check this out any time soon

I can’t believe this issue is still not resolved. Our players can’t use any buttons after a few level changes. We are using 4.15.2.

Please move this to Bug Reports if you can.

Hello Sajuuk,

It’s look like focus problem like keyle said. Can you check it ?

UP, got the same problem and adding set input mode doesn’t change anything to this “bug”

Have you checked the Z-order in your add to viewport issues?

Just tried and doesn’t work :frowning:

What do you mean with “expanding the aadd to viewport” ?
I’ve tried the other things you’ve said and it still does not work sadly, i’ll try combining them differently or whatever might work.

I’ve posted my issue hours ago with screenshots so it’ll be easier to unterstand what happens.

Ok seems like it’s working now with a little bit of delay ! I first placed it in the wrong place but now it’s all good ! I had no clue this could play a role in level loading and all !
Thanks a lot, you are saving me hours of sleep haha !

Expanding the add to viewport and increasing z order is usually the fix for a lot problems. Also opening/closing widgets can fire functionality. Quick hide/show on level entry.

Let’s see what else… if it’s a generated widget recall the generate function on level load if you have one… slight delay after load might also help, start off with a big one and tune down as needed of it fixes the issue.

The add to viewport node has a little arrow you can click that expands it and lets you set z order. The higher the more in front it is.

No problemo, short delays can fix a lot of things on event begin play etc. Just mask it with a loading screen if you need.

Be sure to mark it as solved.

No worries, doesn’t matter. Glad you managed to fix it. As a loading screen I’d just do a black screen with your game logo or just name in text or simply [Loading] as a placeholder and worry about polish like that after the game has full functionality.

Heck put a dirty joke or Scarlett Johansson on there just for fun until later.

Roger that ! Loading screen is the next step.
I can’t mark the topic as resolved as it’s not mine and a old one :frowning:
Thanks again !

This problem won’t occur anymore in 4.20. Steps to reproduce in 4.16:

  1. Open your Multiplayer game in mobile
  2. While connecting to a multiplayers server, touch your finger to anywhere in the screen
  3. After you connect, try touching anywhere.
    Result: Nothing will happen.