Download

UMG Button- from UI input mode back to game input mode?

Hi all,

brand new Unreal user here.
I have created a UMG button which upon hitting changes the texture/material on a Blueprint.
What happens in steps:

  1. I start the level and approach the Blueprint object.
  2. I press the “M” key and the UMG button appears on screen.
  3. I press the button and the graphic on the Blueprint changes to another one.
  4. Immediately after pressing the “M”, the UMG button disappears from the screen.
  5. And here is the problem- I am no longer able to freely look around the level using the mouse without holding down the left mouse button.

At step 1 above when I start the level I don’t have to hold down the left mouse button to look around.

I am attaching the two blueprints I have created- one for the UMG button (widget blueprint) and the other is the Level Blueprint where I edited.

Any help would be greatly appreciated.

After removing your Widget from screen, try to call “Input Mode Game Only” on the PlayerController

Hey ExCluSiv3,
thanks for the help, mate. Do you mean I should add a “Input Mode Game Only” node between the “Remove from Parent” and “Set” in my MenuWidget Blueprint?
Sorry for the stupid question, I am still at the stage where I follow blindly YouTube tutorials :slight_smile:

I am currently at home and that is a work related project so I will try it first thing tomorrow morning.

Thanks again for the help.

He means exactly that!

Thanks to both of you.
That didn’t work unfortunately. I tried 2 options of what you suggested but no cluck.
Maybe it didn’t work because in my Level Blueprint I have used “Set Input Mode Game and UI” and that is conflicting somehow?
But if I don’t use the “Set Input Mode Game and UI” when I try pressing the UGM button the screen keeps rotating…

Any other ideas?

Have a good weekend.

I am having the same problem, anyone know what is going on with this?

Update, changing it to just “set input game mode only” worked, not sure why it didn’t before… I think I didn’t have my blue target wire hooked up.