UMG Blueprint and 'Any Key' Problem


I’m pretty new to Unreal and am currently working on building a main menu. In the UMG blueprint for the main menu, I want the player to need to press any key before being presented with certain options on the menu. In the image below is what I have set up, with the DoOnce node going to the actions I want to take place.

For some reason, when Is Input Key Down is set to Any Key, that Branch node does not return true when I test it out and press any key on my keyboard. If I change Any Key to any specific key, like Enter for example, it works when I test it and press Enter.

Is there something I’m missing as to why Any Key isn’t triggering the Branch to return true?


Hello epeterford,

This may be due to how the Any Key keybinding is set up as it is a new feature. I would suggest, instead of checking via the Is Input Key Down node, making a boolean variable in your player’s BP to be set to true whenever your ‘Any Key’ keybinding is pressed. If you do this, you can do Get Owning Player → Cast to Player BP’s class here > Get boolean variable and plug that into the branch node.

I’ll look into the issue for this node not working with the Any Key keybinding however.

I’ve tested that out myself, with the any key being checked. I’ve also placed a bug in for the issue as it should work the way you had it set up. For your reference, the bug number is UE-25023. I’ll be sure to let you know here when the report has any updates made to it.

Thanks !

Doing what you said worked. I did hook the Cast to Player BP’s class to the Event Tick. Would that be the ‘smart’ way to hook it up? I attached an image of the current setup to clarify.

I would suggest looking into Event Dispatchers so that you could have an event be triggered that executes these nodes when the Any Key is pressed instead of having to call this on tick, but this should work as well. If you do want to learn more about that, you can read up on it here:

They can be a little tricky since they involve communicating between multiple blueprints but if you have any questions about them, be sure to post another question and we’ll try to help you.

A fix has gone in for this issue now and was just put into the Master branch. This means that it is now available on Github if you would like to apply the changes to your source built engine if you’re using it. You can find the fix here: .com/EpicGames/UnrealEngine/commit/b2d9e2e11da1d0be2e0b6fd517ff48214126b8bb

Please be aware that this fix is lumped in with multiple others so be sure to read through the description to ensure that you want to use this fix.

Hello, I still have the same problem (on 4.15.1) and the link doesnt open.

Hello Brokkolin,

I tried following the steps that I placed on the bug report (which can be found here) in 4.15.2 but I’m not seeing the issue. Are you sure this is the same issue that you’re experiencing?

As for the Github link not opening, it’ll give you a 404 error unless you’re logged into a Github account that is linked to your Epic Games account.