UMG Binding to text doesn't work in current project

I can get it to work fine in other test projects, but in the current project I’m working on, nothing is displayed where the bound text should be (other non-bound widgets are displayed) .
If turn off binding, the default value is displayed.
It works fine in other projects, but not my current project.
The project in question was started in 4.4 and updated though pretty much each version through 4.10

Hi, the binding is a variable or a function?
If is a function, did you tried to LogString the output of the function?

Thanks for the response.
Binding is a variable.

Since you said that this is an old project passed by many editor iterations, make sure that the variable type is “Text”, it won’t work with other types.

Yes. Variable type is text.
I tried creating a new project and migrating everything from the old, and still get the same result. Unable to bind variables in UMG. Could be something in the old character actors from older versions?