UMG Binding to Struct Property / DataTable Row not found

Hey guys, is anyone else / has anyone else come across this (what I believe to be a bug in 4.27)?
I’m attempting to bind my item Name text to the “Name” variable in my itemDetails Struct only to be met with long strings of random characters after each of the variables.

I’m led to believe that that it what’s currently causing no rows to be found when I run my game as I have used the same code in a replication made with 4.25 and it works perfectly, no errors or random strings of characters when binds to struct properties.

Any advice would be helpful.

I haven’t seen this happening yet on any version up to 4.26, though I avoid making bindings on widgets at any cost. Instead I use exposed property pins (for construct) or a function inside the widget that pulls required data when required. Is this an option for you?

Hi Seda145, It is an option for me and I’ve tried setting the text to the relevant exposed pin on the struct, once i’ve split it, however the same thing occurs; the rows are not found…

What’s worse is that I can’t exactly roll my project back to 4.26 or earlier either because whenever I do, my maps aren’t able to be opened (as they were created in 4.27) and my characters disappear. The recent update to 4.27 (4.27.1) hasn’t yet solved the issue