Umap/level not being read properly by editor (4.5)

Hi Guys,

We’ve just updated to 4.5 (source code build) and we’re having a problem with some of our levels (.umap files).

When we go to file->open level, we get the new Content Browser style window, but has quite a few of our maps missing:

link:Open Level Screenshot

There should be a noticeable pattern of levels: Room01_DAY, Room01_SUNSET, Room01_NIGHT etc, which are basically copies of each other, but with different lighting to reflect the different times of day. As you can see, all of our Room05 levels are missing, which we initially thought was because of something specific to that room, but then we noticed that other room ‘variants’ were also missing. We have 48 maps in total, but only 34 of them are showing up in the load level dialog.

When we look in the content browser, things get even stranger.

link:Content Browser Screenshot

It shows some of our levels (the ones that show up in the ‘open level’ dialog) in the content browser, but also a bunch of materials and textures. When I hover over one of the materials for example, it does look as though it is getting the information from the missing level .umap files (in the case of the screenshot, “Room05_NIGHT”.)

Here is a screenshot of our maps folder in windows explorer:

link:Windows Explorer

This problem only started happening when we upgraded to 4.5. We’ve tried reverting the .umap files to earlier versions of the maps in case they were corrupted but we get the same issues.

One of the weirder aspects of this is that one of the missing levels is our default startup map, and the game runs fine. We can travel to all of the maps with no problems within the game, it seems to be only the editor that struggles with them.

We still have a lot of work to do on these levels but we can’t do anything if we can’t open them in the editor! If we try double clicking one of the ‘Landscape Material Instance’ files which seem to be being read from our Room05.umap file, I get the following Loading message box:

link:Loading Message

But when the loading completes we just get an asset viewer window with the LandscapeMaterialInstance we tried to open.

link:Opened file

I’m going to try and get 4.4 set up again and try to open the levels with that version to see if it is definitely a problem with 4.5. I should mention that our editor source build also includes the XBox One source code.

Has anyone any ideas on why this is happening and if there is something I can try to get around the problem for now? As I say, the maps load fine in the game, it’s just the editor that has problems.


I have seen this before but not in a while. In the cases where this happens the name of the level is different than the name of the package and it causes your level to show up in the content browser with a different name than the file.

This has been known to happen when renaming levels on disk instead of in the content browser. Renaming levels in the content browser is the preferred way to rename all assets including levels as there can be side effects otherwise.

There may be other ways that your content got into this state, but lets see if we can get it back into a normal state.

Try this:
In the content browser, select all the landscape materials and right click on them (this will load the level packages).
Click on some other folder in the tree view then back to the folder containing your levels (this will refresh the view).
See if your levels now appear. If they do, select them all and resave them then restart the editor. They should show up normally after that.

Hi Milly01,

Unfortunately I have not been able to reproduce this error on our end. Try re-installing to 4.5.1 source build to see if the engine build had an error. Did all of the material assets merge to the maps folder from other filepaths or were they already there?

Hi BobTellez,

We hadn’t renamed any of our levels, so we must have done something else that messed it up.

The good news is that we tried your suggestion and it did seem to work. All the landscape materials/textures are no longer shown (thanks!)

The bad news is that it only fixed 6 of our maps. Now the map folder (and the open level dialog) has 40 entries (before we had 34) but we have 48 maps in total, so 8 of them aren’t showing up at all in the map folder in the content browser, or in the ‘open level’ dialog.

Is there some magic we can do to get the editor to acknowledge the remaining maps?

Thanks again,

The idea is we just need to load then save these maps. You can load a map from console (press tilde key) like this:

Map load file=…/…/…/MyGame/Content/Maps/MyMap.umap

If you know the filenames of all maps that are not showing up you can load and save each one using this method.

Thanks Bob,

That seems to be working great.


I had the same problem with build 4.5.1. The “open level dialog window” did not see some of our maps. I fixed it by changing the default map of the project to one of the maps that was missing from the dialog window.

This option can be found by going to: Edit → project settings… \ beneath project there are some options for Maps & Modes. Set the default editor map to the map that is missing. Next restart the editor, and save the map. From now on it will be visible again from the “open level dialog window”.