.umap file appears to be an asset

UE4 recently crashed shortly after finishing building the lighting in the map, and after re-opening the project and attempting to open said map a message pops up saying “…/…/…/…/…/MaliceTestPlatform/Content/Maps/DesertSands.umap appears to be an asset file!”
And the map doesn’t open. Has anyone experienced this before and knows a fix? There was a large amount of work put into the map which is now inaccessible.

Hi The Scanner Darkly,

Have you attempted to pull the map out of the project, then open the project? If so, save the project, then place the map back into the maps folder and see if that fixes the error. If not, try to move the folder to a new, blank project with no additional content and see if you get the same error. Thank you!

Unfortunately neither of them worked. Both still produced the same error.

Does this happen to any other level? If you feel comfortable with it, I would be happy to have a look at what might be going on with your level.

It’s only that level at the moment, how would you like me to give it to you? Do you need just the umap file or the whole project?

Hi Scanner,

Just the Umap should be sufficient. If you can upload it in a .zip here that would be fine, or up to a FTP server such as dropbox and post the link I’ll grab that.

Zipped it up for you, thanks for taking a look!
https://dl.dropboxusercontent.com/u/5210835/DesertSands.zip

Hi The Scanner Darkly,

I definitely see what you were talking about and have been able to reproduce this on my end. I have attached this conversation as well as my findings to a bug report to be assessed as, in all honesty, I am not entirely sure what happened. This is a very strange situation. Please bear with us while we try to sort out what exactly occurred and how it can be addressed. I will leave this question open until I can get back to you with more information.

Hi Scanner Darkly,

One of our developers is having a look at this and would like to know a bit more information so they can see what happened, as currently the file is showing that there is no world within the file. What were the steps you were taking leading up to the crash and do you happen to have that specific crash log available so we can see what occurred? Thank you!

The engine crashed right after loading the project up, before everything had actually initialized, so I assume some things were still being loaded, and it was a straight “.exe has stopped working” and the regular crash report client didn’t show up, there’s no crash report logs in the usual spot (unreal engine/4.3/Engine/Programs/CrashReportClient/Saved/Logs/. I think?)
I think what may have caused the crash was a lack of ram, as I had many programs open at the time, 3ds max, photoshop, quixel suite and was sitting at about 70% usage before opening UE4.

Try looking in the file /UnrealProjects/PROJECTNAME/saved/logs/. There may be something in there that could be useful here. What changes had been made to the project in the editing session before the crash?

Not sure what files exactly will be helpful, so I’ve attached all the files dated around the day of the crash which was the third.link text

That’s all-right, we’ve managed to re-create the map and some more now, so not getting the map back isn’t really a problem. Still good to know it’s being investigated so it doesn’t happen again :slight_smile:

Hi Scanner Darkly,

I wanted to let you know that this is still currently under assessment by our development staff. I unfortunately do not have a timeframe for completion. Thank you and have a great day!

I am happy to hear you are able to continue working! I will mark this question as accepted for tracking purposes. If you start to experience this problem again please comment and let us know so we can attempt to get to the root of the error.

Does the map load correctly when running the game? I’m having a similar problem at the moment with some of our umap files in the editor, but the game opens them fine. I don’t get the “xxx.umap appears to be an asset file!”, but assets do appear in the asset viewer instead of the umap.

Here’s my thread on my problem

I know this isn’t really an answer, but it does seem like a related problem.

Cheers,

Matt

have you used some backup files.
check this out.

This same error just happened for me in UE 4.25.1. Backups also won’t open.