UI flickering @(UE5.0.1)


Hi guys
I am working on Alienware area 51 laptop with 2080 RTX Nvidia
and when i open UE5 the editor flicker like it shown in the attachment
it happen sometimes in UE4.27 but not that much so i can manage but it happen aggressively like it shown in the video attached

I tried the Nvidia studio drive 512.15 and still no fixing for the problem
i also update the Nvidia drive to 512.59 studio version and still have same problem

please help

any idea how to fix that

Having the exact same issue.
Gigabyte k5 rtx3060 win10 Pro 21H2

I’m having the same problem with:

  • UE 5.0.3
  • Win 11
  • Alienware laptop with RTX 3060
  • Up do date Nvidia driver - 516.59

I’ve tried disabling GPU switching, setting UI scaling to 100%.

I just tried connecting the laptop to an external display via HDMI, and the editor works fine on the external display but starts flickering again the moment I bring it back to the laptop display.

I have the exact same computer and the exact same issue, has anyone found a fix yet?

我3080Ti 也不稳定 找到解决办法了吗

Hi all,

I think this was just solved in another thread with this solution: Open Project Settings and change ‘Default RHI’ to “DirectX 11”

Although be warned that some features (Like Nanite) require DirectX 12

Good luck

3 Likes

Thanks for sharing, this has stopped the flickering and at least let’s me use the editor on the laptop screen.

the only permanent solution that i found that also lets you use directx12 is attaching a second screen. for some laptop brands the screen is hardwired to run on the internal GPU, using an external screen solves this issue as it forces everything to run via dedicated GPU, i have the same PC as the OP and this solved it instantly

On nvidia, overlay test mode creates this issue.
Please run attached reg, in your registry file.
Problem will be solved.
mpo_disable.reg (252 Bytes)

1 Like

Hey guys.

Navigate project settings, switch to Direct11 and restart the session. This fixed it for me and I was able to go back to Direct 12 with no further issues after that.

Restoring system to before recent updates seam to have fixed the issue

Same problem here. My specs Lenovo Legion 5i pro 2022 12700h 3070ti. It started doing today after some new windows updates. I have my laptop set to dGpu. I tried solutions here provided but it didn’t do anything.

The solution is posted above but seems scammy but it works (sorry, CtnDev - I’d never run a file posted by anyone :slight_smile: )

Regardless, I did track down the issue. Here is the link to the NVIDIA site, which is likely the same file that CtnDev posted: After updating to NVIDIA Game Ready Driver 461.09 or newer, some desktop apps may flicker or stutter when resizing the window on some PC configurations | NVIDIA

This solved my problem on my Alienware x15 3080ti

Moving to DX11 also fixed the problem, but I want all that DX12 goodness so it wasn’t really a solution.

1 Like