Download

Ugly Seams Issue

Hi everyone,

I am using Datasmith to import a building from Revit 2019 into UE4, and I have very ugly seams between walls (see below)

Basically, everywhere two walls meet, you can clearly see the joints between them.
Is there a way to have a smooth transition in UE4 between two walls made in Revit?

Thanks,
Antoine

is lightmap resolution is vary to walls.

My walls have different lightmap resolutions, however they have very similar lightmap densities.

Look at the first screenshot below: We can clearly see the seams between the 4 different meshes, they even look like they have different materials applied to them but they don’t. It’s all the same one material applied on the 4 different walls.

And here is a screenshot of the lightmap densities. Shouldn’t it make all those walls look similar?

Thanks for your help!
Antoine

its a light leakage. import your scene in 3dsmax and make outer shell to block light leakage. and make outer shell hidden in game. dont turn off cast shadow.
Please subscribe and support Youtube channel

I thought the point of Unreal Studio and Datasmith was to be able to import scenes directly from Revit instead of having to go through 3dsMax first…
Thanks for your help, I will try that

What bake quality settings are you using? To me it looks like the quality may be too low regardless of how high your lightmaps are.